#1534 --- Failed installing 'openhab-misc-restdocs'

Reading is a gift, which not everyone has :wink:
Thanks !

1 Like

I’m getting the same errors with build 1557. I’ve installed the rest docs adding via Paper UI and it says it’s installed.

My addons.config is empty beneath the UI comment. Can I simply add ui = restdocs (No quotes) and that fill fix the problem?

also have the same issue now with #1558.
Does the error message mean that there is a link to something that does not exist anymore…restdocs not being whatever it was before becoming an UI?

hm, my addons.conf in /var/lib/openhab2/config/org/openhab (not sure if this path is the one to blame)…
i see the following:



So there is misc=restdocs…is this outdated? i normally do only add/remove via PaperUI.
Do i have to remove it manually via commandline?..if i want the docs again, i can reinstall them in UI from PaperUI?



Yes just remove the line:

from that addons.config file.

Then restart openHAB and install the REST Docs via Paper UI, Add-ons, User Interfaces:


Hi, i did what you proposed…mostly. i let misc="" arround but that should not have any impact i guess…

but now i see the following error log in openhab.log

2019-03-23 21:47:49.681 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing ‘openhab-ui-restdocs’: Error restarting bundles:
Exception in org.eclipse.smarthome.io.rest.sse.internal.SseActivator.start() of bundle org.openhab.core.io.rest.sse.

ah found the following…again in the snapshot jungle…why didn’t keep calm and stay with #1512 uaaaahhhhhhhh

It’s a known issue. Just restart openHAB and the exception should be gone:

Yesterday I installed 2.5.0-Snapshot with openhabian.config

Since then a have several problem one of them is, that I geht this message several times per minute:

2019-04-01 09:49:28.805 [INFO ] [thome.model.lsp.internal.ModelServer] - Started Language Server Protocol (LSP) service on port 5007

2019-04-01 09:49:28.831 [ERROR] [core.karaf.internal.FeatureInstaller] - Failed installing 'openhab-misc-restdocs'

This two messages rise everytime together! How can I solve it?

I have solved, as managed a few posts above.
Go to the directory: /var/lib/openhab2/config/org/openhab
Edit file : addons.config
look for the misc= line and delete param restdocs


I have the same error, but my addons.config has the following in MISC?

Any Ideas.


I have no text file at all referencing rest docs but get this error constantly through all the versions since over a month (since I took notice of it).

Can that be any relic from an old version? I am using OpenHAB on this instance since 2.1.

I have the same problem, although with openhab-action-mail.

This is different from the original issue. You probably didn‘t notice that the mail-Action has Been moved to the legacy addons and is replaced by a new mail binding. You need to enable „legacy addons“ to use it.

Yes, I know. Is there a way to remove ‘mail-Action’? I have not found a way yet, neither in Paper UI nor in the carafe console. I cannot find ‘mail-Action’ in bundle:list.

How did you install it originally? Probably in addons.cfg?

Nope, neither 'services\addons.cfg nor ‘addons.config’ was not used.

I had the same problem with 2.5.0.M2 and Mail-Action.
I got the problem solved after enabling Legacy v1.x Binding Support.
Then I could UNINSTALL the old Mail-Action Bindings.

1 Like

I have this same issue. Can’t find a 1.X version to install to remove, it was never in my addons.cfg. On 2.4M4.

You meen 2.5M4? I just did as described above with great success, remove the line misc=“restdocs” from addons.conf: