2.5.0.M2 LSP and VSCode works partially

Tags: #<Tag:0x00007fc1fe861150>

I upgraded from 2.4.0 to 2.5.0.M2.
It looks like the LSP does not work together with VSCode any more.
This is my workspace setting, vevedock-64 is my host:

{
    "openhab.host": "vevedock-64",
    "openhab.port": 8080,
    "openhab.lspPort": 5007,
    "openhab.lspEnabled": true,
    "openhab.restCompletions": false,
    "workbench.iconTheme": "openhab",
    "openhab.karafCommand": "ssh openhab@vevedock-64 -p 8101 -t 'log:tail'",
    "git.ignoreLegacyWarning": true,
    "terminal.integrated.shell.windows": "C:\\WINDOWS\\System32\\WindowsPowerShell\\v1.0\\powershell.exe"
}

openhab.restCompletions": false was neccesary in 2.4.0 due to havy cpu load in 2.4.0.
Is this a problem now?

the suggestions I get:

errors are not marked as such

1 Like

I have the same problem.

Did you manage to solve it somehow?

No, not yet

@Confectrician, @kubawolanin, @rlkoshak please give a helping hand.

In order to prove that my vscode setup is ok, I created a new fresh docker container with version 2.4.0.
I copied my configuration from the 2.5.0.M2:

{
    "openhab.host": "vevedock-64",
    "openhab.port": 8080,
    "openhab.lspPort": 5007,
    "openhab.lspEnabled": true,
    "openhab.restCompletions": false,
    "workbench.iconTheme": "openhab",
    "openhab.karafCommand": "ssh openhab@vevedock-64 -p 8101 -t 'log:tail'",
    "git.ignoreLegacyWarning": true,
    "terminal.integrated.shell.windows": "C:\\WINDOWS\\System32\\WindowsPowerShell\\v1.0\\powershell.exe",
    "python.linting.pylintEnabled": true,
    "python.linting.enabled": true
}

And it worked right away:

So it for sure has to do with 2.5.0.M2.
Can that somebody verify?
I personally do not know what I may have done wrong.

Was it fixed in 2.5M3 ?

I’m not an expert in VSCode and the LSP so I’ve no ideas or suggestions. I’ve not had the opportunity to use VSCode in quite awhile, at least for Rules DSL development so I’ve not had opportunity to see similar problems.

I would have expected setting restCompletions to false might have caused this behavior but your test shows that it works in 2.4 with that set to false. I’ve no clue what it could be.

It might be worth filing an issue, https://github.com/openhab/openhab-vscode. You’ve shown that it works in 2.4 but not 2.5 M2. Bruce has a good point though, try it in M3.

1 Like

I created issue 141.
It does not work on both M2 and M3.
Set also debug to trace, not tracing anything.

1 Like

I have replied over there and i think we have to look on the server side for this.
There should be no changes since 2.4.0 or it would have been caused by our big lsp change.