2.5M4 Intermittent mega-delays on Z-Wave

Since I upgraded to 2.5M4, I have serious issues with looong delays in my zwave network.
Normally they arrive after about one day, so I have restarted oh about once a day.

It seems to kind of mend itself, I mean, you can see that there’s some traffic coming again after the ~10 minutes, but in reality the nodes can’t be controlled from e.g. basic UI. In fact just now, when I tried to control my office lamps, the binding has been frozen for about ten minutes again.

Here’s a snippet with about 10 mintute delay;

Node 84 is a battery device. Not sure if it has been 84 previous days.

I have been running on 2.4 until October, and I haven’t tried the earlier Milstone releases.

Now, looking at the Aeotek Z-stick controller, it does not cycle its led, frozen on blue.

My zw network consists of about 80 nodes.

I’ll take out the batteries on node 84 before restarting oh again, to see if it is the node that brings everything down.

If anyone has another suggestion what to try or test … :confused:

Disable network heal. Search the forum before posting please.

It was never enabled. Forum searched for my problem, but I could not find any similar issue. Hence the post.

Again, my problem is not related to heal.
But for others having this problem, I simply removed the batteries on node in question, and now my network seems to work again. Have had run stable it for three days now. Something must have changed between 2.4 and 2.5M4.

The node is one of my oldest zwave components, an Ez-motion 3in1, so I decided it should be retired. Problem solved I hope. Strange that the controller hanged though.

sometimes a flakey node can swamp the network.

probably the flakey node, like stated, was swamping the zwave network. At some point it gets bad enough that the controller is so backlogged trying to do stuff, the controller appears hung.

We’ve had more then a few cases where someone upgrades to a newer version of OpenHAB, then begins to have problems with the zwave binding and the natural assumption is that the upgrade caused the problem. After much investigation and reviewing the logs, the problem turns out to be a battery device with low batteries or some other problem that was there all along and just not noticed until the upgrade
Please let us know if your problem is in fact fixed, report back and if so mark the thread as [SOLVED] thanks

Yeah, maybe. Although I find it bit hard to believe that the node broke on the update. It has been working for about 6-7 years. It might be that it has some bug that set off the issues in 2.5 though. Batteries not too bad, maybe 2 months old. Well, anyway - I’ll report back if this is the end of the issue in a couple of days. I don’t have the stamina to verify that that it still works fine in 2.4. :slight_smile:

Try deleting (not excluding) and re-discovering the Thing from OH. The id will stay the same and it will get any new binding configuration.

From what version?

1 Like

Not trying to be the smart ass here, just trying to help. I completely understand that you do not have the time to read each and every topic here on the forum.

1 Like

So, I decided to do some more testing. I deleted the thing, inserted the batteries and woke the node manually. Not much seemed to happen, so I restarted oh, woke the node re-added the new thing from inbox. Then after a wile the controller hung again. I stopped oh, pulled the controller and reinserterted it again, and started oh, a last time. The network seemed to work until:

So I closed down oh again, removed the batteries of 84, pulled the controller and reinserted it again, and restarted.

I have the complete log since the last restart, if you @chris are interested in this. I don’t mind putting my old 84 into the recycling bin, but if this is might help others upgrading to 2.5, it might perhaps be useful.

I suppose I should exclude it and reset it. Maybe I’ll do that later on, just to see if it makes any difference. But since the whole house is frozen, it is kind of annoying. :slight_smile:

Sorry - I missed that. There haven’t really been a lot of updates since 2.4 and I don’t think there were any fundamental changes other than the change to the serial drivers to use the new OH driver.

I’m happy to have a quick look at the log though, although I’m not sure it will show a lot. It looks to me like there is no communication with the controller during this period as there are not even any RX ACK messages when commands are sent.

1 Like

I think the controller gets into hanged state, the LED’s indicate this. The log is linked in my last reply if you want to take a look.

Unfortunately the log doesn’t show any problems - just that the controller stops responding. It could be an issue with the serial port, or drivers, or the controller - it’s hard to say.

The code in the binding to send/receive data via the serial port has not changed for 3 years, other than to change some logging statements in the event of an exception.

1 Like