2 Homematic-IP-Thermostats are always set together


A few days before I installed two newly bought Homematic IP Thermostats.First I added them to the raspberrymatic and the status and control via webui works fine (still).

Then I added them to openhab (2.4.0). There are other homematic things in my installation from before (even 1 other thermostat) and all of them work fine.

The problem with those two new things is, that I cant control them separately. If I change the temperature on one of those two, the other changes its setting as well (see log below)!!

Where did I make the mistake?

Regards, JĆ¼rgen.

LOG after changing HK_WohnzimmerEsstisch from 22.0 to 22.5

2020-03-11 10:49:32.940 [ome.event.ItemCommandEvent] - Item ā€˜HK_WohnzimmerEsstisch_SetTempā€™ received command 22.5
2020-03-11 10:49:32.950 [nt.ItemStatePredictedEvent] - HK_WohnzimmerEsstisch_SetTemp predicted to become 22.5
2020-03-11 10:49:32.967 [vent.ItemStateChangedEvent] - HK_WohnzimmerEsstisch_SetTemp changed from 22.00 to 22.5
2020-03-11 10:49:35.249 [vent.ItemStateChangedEvent] - HK_WohnzimmerSofa_SetTemp changed from 22.00 to 22.50


Bridge homematic:bridge:raspiccu [ gatewayAddress=ā€œ192.168.178.43ā€, gatewayType=ā€œautoā€, callbackHost=ā€œ192.168.178.69ā€ ]
Thing HmIP-eTRV-2 000A18A99426D7 ā€œHeizkƶrper WZ Esstischā€ @ ā€œErdgeschossā€
Thing HmIP-eTRV-2 000A1A49A13771 ā€œHeizkƶrper WZ Sofaā€ @ ā€œErdgeschossā€


Number HK_WohnzimmerEsstisch_AktTemp ā€œHeizkƶrper WZEss MessTemperatur [%.2f]ā€ (gTemp) { channel=ā€œhomematic:HmIP-eTRV-2:raspiccu:000A18A99426D7:1#ACTUAL_TEMPERATUREā€ }
Number HK_WohnzimmerEsstisch_SetTemp ā€œHeizkƶrper Wohnzimmer Esstischā€ (gTemp) { channel=ā€œhomematic:HmIP-eTRV-2:raspiccu:000A18A99426D7:1#SET_POINT_TEMPERATUREā€, alexa=ā€œThermostatController.targetSetpointā€ }
Dimmer HK_WohnzimmerEsstisch_Level ā€œHeizkƶrper WZEss Levelā€ { channel=ā€œhomematic:HmIP-eTRV-2:raspiccu:000A18A99426D7:1#LEVELā€ }
String HK_WohnzimmerEsstisch_ValveState ā€œHeizkƶrper WZEss Statusā€ { channel=ā€œhomematic:HmIP-eTRV-2:raspiccu:000A18A99426D7:1#VALVE_STATEā€ }
Switch HK_WohnzimmerEsstisch_LowBatt ā€œHeizkƶrper WZEss Batterie leerā€ { channel=ā€œhomematic:HmIP-eTRV-2:raspiccu:000A18A99426D7:0#LOW_BATā€ }

Number HK_WohnzimmerSofa_AktTemp ā€œHeizkƶrper WZSofa MessTemperatur [%.2f]ā€ (gTemp) { channel=ā€œhomematic:HmIP-eTRV-2:raspiccu:000A1A49A13771:1#ACTUAL_TEMPERATUREā€ }
Number HK_WohnzimmerSofa_SetTemp ā€œHeizkƶrper Wohnzimmer Sofaā€ (gTemp) { channel=ā€œhomematic:HmIP-eTRV-2:raspiccu:000A1A49A13771:1#SET_POINT_TEMPERATUREā€, alexa=ā€œThermostatController.targetSetpointā€ }
Dimmer HK_WohnzimmerSofa_Level ā€œHeizkƶrper WZSofa Levelā€ { channel=ā€œhomematic:HmIP-eTRV-2:raspiccu:000A1A49A13771:1#LEVELā€ }
String HK_WohnzimmerSofa_ValveState ā€œHeizkƶrper WZSofa Statusā€ { channel=ā€œhomematic:HmIP-eTRV-2:raspiccu:000A1A49A13771:1#VALVE_STATEā€ }
Switch HK_WohnzimmerSofa_LowBatt ā€œHeizkƶrper WZSofa Batterie leerā€ { channel=ā€œhomematic:HmIP-eTRV-2:raspiccu:000A1A49A13771:0#LOW_BATā€ }


sitemap Homematic label=ā€œHomematicā€ {
Frame label=ā€œHeizkƶrper Wohnzimmer Esstischā€ {
Default item=HK_WohnzimmerEsstisch_AktTemp
Setpoint item=HK_WohnzimmerEsstisch_SetTemp minValue=17.0 maxValue=24.0 step=0.5
Default item=HK_WohnzimmerEsstisch_Level
Default item=HK_WohnzimmerEsstisch_ValveState
Frame label=ā€œHeizkƶrper Wohnzimmer Sofaā€ {
Default item=HK_WohnzimmerSofa_AktTemp
Setpoint item=HK_WohnzimmerSofa_SetTemp minValue=17.0 maxValue=24.0 step=0.5
Default item=HK_WohnzimmerSofa_Level
Default item=HK_WohnzimmerSofa_ValveState

Both your Things have the same UID. Only one will ā€œwinā€.
Your Items are linked to the same Thing.

EDIT - okay Iā€™ll take that back having read the docs. Homematic uses the serial part 000A18A99426D7 as the UID.

Still looks like they are cross-linked though, I wonder if a leftover from earlier edit/copy/paste.
Have you restarted the binding since last editing your Things and Items files?
Small in-flight edits can be missed by many bindings.

I canā€™t believe it. I would bet I tried a restart already, butā€¦ what should I sayā€¦ a restart of the whole system solved the problemā€¦
Thanks for your advice!!!

1 Like