2nd endpoint not exposed in Zwave blinding for Qubino Flush Shutter, release 2.1

hi @chris, let me reopen the discussion here. With release 2.1 the blinding does no longer expose the 2nd endpoint (binary_switch2) for the Qubino Flsuh shutters in venetian mode. Both Habmin and the PaperUI does only show the first endpoint (blinds movements).

After upgrading to 2.1 I deleted and re-included the items in habmin (misreading I had to do this for the security stuff). It could be this is because the binding hasn’t updated the node yet and still needs to discover it is actually in venetian mode, so I left it running over night. Still no change today. How can we force the binding to expose the 2nd endpoint. In the past this was done by default, even if the Qubino was not in venetian mode, giving one the option to address it in any case.

Thanks for your help, Markus

What device is this for? Can you provide the link to the database so we can see what is defined.

Sorry, forgot to paste this, it is ZMNHCD.

Looking at the database there are two versions of this device - I’m guessing you have the older one (version below 4) as the other one does have the extra endpoints.

My guess is that the database needs updating for your (presumably older) device?

I was told by Qubino that my firmware is old, yes (there is a firmware bug in them for the state machine in venetian mode, needs separate fixing). It worked with release 2.0 and didn’t break when updating to a unstable 2.1 build (without deleting the items in habmin). Now after deleting it the problem appeared.

Ok, so the database needs to be updated then for the older device. I guess at some stage this changed and now doesn’t contain these channels.

What do I need to do to try this ?

We would need to manually add the endpoints and command classes that your device uses. Unfortunately this can’t be done automatically since the database won’t add endpoints/classes if the device is already in use.

The XML file for your device should show the endpoints and command classes it uses, and then add the channels (the same as the newer device I guess).

The old device is below -:


Just a word of warning - the database can get confused if you have multiple windows open, so avoid cut and paste from one window to another as this is likely to cause a mess :wink:

ok, I’ll look at it late this evening (after work).

Hi @chris, tried to create an login account, but can’t get the system to send me a confirmation email ?

I am confused by the DB, I see 3 entries, one for < v4.0, one > 4.1 and one for all. Is this on purpose ? Shouldn’t we drop “all” ?

You are right to be confused - I’m also confused! The “all” version was just added in the past couple of days. I’ve emailed the person who added it to ask them why this was done - maybe it’s just the version numbers are wrong or something - I don’t know. If I don’t get an answer in the next few days I will mark this as removed…

Anyway, this shouldn’t impact you for now since I think you have the <4.0 version?

Can you PM me your user name and I’ll activate your account tonight.

Hi @chris, my version is 1.1, see screenshot attached. What I am confused about is that it shows up as MOTOR_CONTROL_CLASS_C, while the version < 4 description is version MOTOR_CONTROL_CLASS_B ???

At the same time the “all” version as well doesn’t have the 2 endpoints. It seems there is more than one problem in the database. What shall we do with this ? If we need 2, then they both should have 2 version, “all” seems to be a copy.

PS: I email you my account name.

Attached the XML. In the XML is says version 4, it has the 2 endpoints at it should and it is MOTOR_CONTROL_CLASS_C. I think the entry for version up to 4 is wrong, version 4 is definitely a MOTOR_CONTROL_CLASS_C and not MOTOR_CONTROL_CLASS_B.

node25.xml (25.8 KB)

Hi @chis, there are more issues, like the parameter 73 is incomplete w.r.t. the documentation. I don’t know who changed the DB entries, but there is a lot wrong now. Can we revert this, it was ok before ? Is there a history somewhere for recovering it ?

I can confirm I am loading for my V4 nodes the DB entry “All up to 4.0” version, as the comments in HABMIN refer to this version and not to the others !

I have uploaded the XML from my node (V4.0) to this DB entry, I hope this is the right one. @chris, do you want to “review” this XML or shall I try to edit the page interactively in the browser ?

Ok, done, I hope.

The version is here:


I did one mistake, I had added Command Class “ASSOCIATION_GROUP_INFO” in endpoint 0 twice and it now gives me an error. I couldn’t figure out from the interface how to delete it again (stupid me).

There is another issue in the configuration I wasn’t able to fix, for “Parameter 73” there is the “Option Value 0” twice and the 2nd one needs to be deleted. Same problem as above, I couldn’t do it. Note, this issue is AS WELL in the configuration “after 4.1” (http://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/213)

I tried to put the correct versions for all command classes (and correct them where they were wrong before) based on the document.

I commented at the bottom that this is now compatible with V4 as it is supposed to be.

Best, Markus

Hi again, no success here.

I have downloaded the org.openhab.binding.zwave-2.1.0-SNAPSHOT.jar and replaced the qubino_zmnhcd_0_0.xml with what I got from the database. I loaded it on my RP and made sure the bundle works in karaf (dependency), making sure that is active. Then I was reloading the nodes (delete them, rediscover).

The net result is disappointing, I do see the new endpoints, the value option is fixed. If I try to turn the blinds, I get
2017-06-30 02:39:34.235 [WARN ] [ding.zwave.handler.ZWaveThingHandler] - NODE 73: No command converter set for command zwave:device:29a8e9c7:node73:switch_binary2 type OnOffType

slimilarly, if I try to run them up/down, I get:

2017-06-30 02:40:20.661 [WARN ] [ding.zwave.handler.ZWaveThingHandler] - NODE 73: No command converter set for command zwave:device:29a8e9c7:node73:blinds_control type UpDownType

This is beyond my knowledge and I don’t know how to debug this further. I need help on this, @chris.

PS: I do believe the v4.1 version of it has as well more problems, but since I can’t get this one to work, I am not sure.

No - not stupid you ;). Delete is only available to admin - just for safety :wink:

I will fix this and also the parameter 73 issue.

I will have a further look at this tonight.

I don’t see any sort of error so all I can suggest is to get a debug log during the binding start to see if that shows anything.

hi, debug log attached. I keep looking at it, can’t figure out what is work. Tried to drive one of my blinds up/down or open blinds.

Logfile is here