3rd Party Bluetooth Binding. Beta testers needed

Wow that’s bad. Did it blow straight away or after some time? Did you have a load on it (bulb)?
Mine is stuck in customs ATM should have it soon.

What is very interesting is the construction, you can clearly see a separate power and logic board (with bluetooth controller), having only a 2 pin power connection. I don’t see how it’s doing a control line for switching/dimming. I bet that logic board might still be good. Might do an eevblog when I get mine… Don’t turn it on, take it apart!

My units arrived this morning, I have taken both apart, they look very well made overall.

The wireless one uses the exact same PCB with no changes (hardware), it only has a different back plate holding the CR2032 battery.

Exactly how the logic board is talking to the power/dimmer board is still a mystery to me, maybe its using one of the PWM pins along the GND or 3.3V lines as a signal?

From your photo it looks like yours failed over two zero ohm resistors which would have acted like fuses. Some how it passed way much current (very high wattage bulb/no bulb to limit the current?).

When i get home i’ll get some photos ect and then to testing this week.

The micro controller used is this one which is a common one used for Bluetooth rgb bulbs (TLSR8267).

I don’t think that this device is a “normal” dimmer. This is a part of Yeelight infrastructure, e.g. wireless controller for some Yeelight bulbs/lights. What you do is:

  1. Install Yeelight bulbs or other “lights”, connecting them as per normal appliances, e.g. “neutral” and “live”. These light work from 220v, and cannot be dimmed by reducing voltage.
  2. Install Yeelight controller, same way - like an appliance.

Have a look at MiLight hardware, it is similar but not bluetooth.

That’s what I did, I wired it up with “neutral” and “live” and it blew up. I’m not saying that it is correct, this is what I’m used to do with MiLight and since there is not any manual/instructions on how to install this I assumed that it works like MiLight, maybe I’m wrong but I don’t see any potentiometers in this device and as you correctly noticed, the controller board does not have any connection to the power board apart from 3.3v terminals. Effectively that power board is just AC/DC converter (220v ac to 3.3v dc), again I might be wrong, but that’s what I see.

BTW, Banggood proposed to refund my unit, so I’m going to accept this. Furthermore, I don’t see any proper certification signs, so it would be difficult to comply with building code (at least here in NZ).

Hi guys, not sure what has happened but the miniNuts I’ve had have been working fine until yesterday then suddenly they both appear offline in PaperUI at the same time…checked the nuts and both work so I then checked the logs:

2019-04-24 21:47:48.726 [WARN ] [th.manager.impl.BluetoothManagerImpl] - Disposing Bluetooth manager: 16b663c

2019-04-24 21:47:48.733 [WARN ] [impl.AbstractBluetoothObjectGovernor] - Disposing governor: /B8:27:EB:79:AC:CE/DE:75:49:A7:6B:C3

2019-04-24 21:47:48.736 [WARN ] [impl.AbstractBluetoothObjectGovernor] - Disposing governor: /B8:27:EB:79:AC:CE/CD:F6:54:D4:B1:97

2019-04-24 21:47:48.738 [WARN ] [impl.AbstractBluetoothObjectGovernor] - Disposing governor: /B8:27:EB:79:AC:CE

2019-04-24 21:47:48.773 [WARN ] [oth.internal.BluetoothHandlerFactory] - Extension folder does not exist, ignoring it: /home/pi/.bluetooth_smart

2019-04-24 21:47:48.832 [WARN ] [.core.thing.binding.BaseThingHandler] - Handler BluetoothDeviceHandler of thing bluetooth:ble:DE7549A76BC3 tried checking if channel online is linked although the handler was already disposed.

The Pi Bluetooth adapter is online and a thing…

I’m pretty sure I’ve not changed anything on the pi, I’ve added a few unrelated things and played with a few unrelated rules…

Anyone have any ideas on what the logs mean? Should I remove and re-find the nuts? Would be good to know what caused it so I can avoid the issue in future.

hi @MadFrankie, for how long have you been running the binding?

The logs you’ve provided don’t indicate anything bad.

Have you done any system upgrades y any chance recently? Maybe your bluez has been upgraded?


It’s been working about 13 days, and working fine.

In that time I’ve done pretty much nothing on OH due to lack of time. I did install hping as per:

but it didn’t work properly for me so I’ve commented out all the items / rules etc. Could it be this that has changed something? The problem is that I can’t say it the nut was working before I did this as I’ve not been on OH to see the few days before it…

Great binding and works fine with the devices that are recognized with BLE enabled devices. For example, I’ve a Bose headphone and it is showing it online and works well.

Has anyone came to a solution to keep IPhone awake using Bluetooth, it only works if you’re in a Bluetooth settings in IPhone. Not sure if having a Bluetooth adapter will solve this problem?
Any thoughts?

Did you find any BT dongle with longer range? I am interested to know.

Hi @alijaf, please have a look here: 3rd Party Bluetooth Binding. Beta testers needed

This is a new feature that needs to be tested. Let me know how it goes.

Thanks Vlad, I did install the app and played around but again it still keep the Iphone device disconnected and the newly device that we get using that App that you have mentioned. I think I’ll just wait for my nutMini to arrive and will link that along with the phone to make the presence more accurate unless you’ve any other better suggestion.

Quick stupid question : is it possible to do text based configuration instead of using PaperUI ? (using .things /.items files).
I didn’t find any examples.

Not sure if this helps testing / anyone…

I’ve just uninstalled the 3 bindings, (BlueG / Tiny and the main Bluetooth binding), restarted my RasbPi and then re-added all the bindings again and now the bluetooth binding is working again.

As mentioned in the above post, the only thing I’ve done to my OH is add the hping binding so wonder if one knocks out the other…but so far all seems well again :+1:

Scrap that, it worked, ie it found and connected to the nut and then I got the relevant data back, (location, online, etc), I walked away happy.

I’ve just gone back to it and noticed that after that first connection it now won’t connect and hasn’t connected since…

Anyone any ideas?

For those interested, I came up with these text config :

Thing bluetooth:adapter:B827EB50CAC4 "BT openHABianPi" 
Thing bluetooth:ble:FAE38022F32E  "BT edi1" 


Switch BT_beacon_Online "My Beacon Online" { channel="bluetooth:ble:FAE38022F32E:online" }

Switch BT_beacon_Connected "My Beacon Connected" { channel="bluetooth:ble:FAE38022F32E:connected" }

String BT_beacon_NearestAdapter "My Beacon Nearest Adapter" {channel="bluetooth:ble:FAE38022F32E:adapter"}

Number BT_beacon_batterylevel "My Beacon Battery Level" {channel="bluetooth:ble:FAE38022F32E:180F-2A19-level"}

Good stuff.

@William, @MadFrankie, just so you know that I do not recommend enabling “Connection control” channel for beacons, you don’t have to be connected for presence detection.

1 Like

good to know :slight_smile:
did not really understand what is this for …
i use only beacons …

So guys I ordered two of the Nut Mini devices and they came today, the interesting situation that I am going through is that the first one works fine and as soon as I add the second one the first one just goes offline. Has anybody experienced this or anybody using two Nut Mini’s together? and if there is anything special that is required to configure two of those to work together correctly? Ideally I’d be creating a Group Switch to use it for presence along with Phone group.

I am also looking for answer on this.

Can you please post a screenshot of your thing settings here? Looks like some of nut devices incorrectly identify themselves.

Hi @alijaf, please have a look here: https://github.com/sputnikdev/eclipse-smarthome-bluetooth-binding/issues/83

I assume it is the same issue you are having. The workaround for now is to add your nut devices manually.