3rd Party Bluetooth Binding. Beta testers needed

bluetooth
binding
Tags: #<Tag:0x00007fd30f29a8f8> #<Tag:0x00007fd30f29a7b8>

(Vlad Kolotov) #382

BTW, @Dibbler42, don’t forget to update firmware in your MiFlora devices. Old versions do not advertise anything meaningful.


(SiHui) #383

May I ask which one? Thx.


(Thomas Bail) #384

@vkolotov Thanks for the advice. Checked all the firmware versions all at 3.1.8


(Thomas Bail) #385

@sihui Oh that is just a long usb cable here is the amazon link Inline USB Did you know that if you use smile.amazon.?? you are able to select openhabfoundation and amazon will donate some money

My second appraoch to extend bluetooth ist to use uspip. Place some raspberries around the house and bring bluetooth over ip to openhab


(SiHui) #386

Yepp, that’s what I already do since a couple of month

Yes, but what bluetooth device/extender is attached to it?


(Thomas Bail) #387

It is a “LogiLink BT0015 USB bluetooth V4.0 EDR Class1 Micro, CSR Chip” i bought some of them to read my miflora devices with the Miflora deamon brought by ThomDietrich


(Alexandr) #388

Hi @Dibbler42

You can try this solution for the extending the “range”.


(Vlad Kolotov) #389

Great finding @Balaganov, I might try it later. Thanks


(Alexandr) #390

It was already found by @gitMiguel. Right in this topic #136. Thanks to him.
But my Rpi sd card was broken again. And I can’t try this solution.


(Thomas Bail) #391

As i understand it is a serial connection over LAN. the zwae dongle is connected as a serial device to the raspi and therefore a serial port is forwarded over the net.

As far as i know a BT dongle is no serial device. or am i wrong with this?

I tried another solution: usbip. Work on the server side like a charm, but until now i was not able to bind anything at the remote site. get a listing off the devices, but the attach does not work.


(Markus S.) #392

Hi there.
After a new installation on ubuntu, i can’t see the four mi flora channels of humidity, temperature and so on. All other channels are there.
What i am making wrong. Can you help me?
Thanks,
Markus


(Vlad Kolotov) #393

Hi @Master79, could you please clarify “where” can’t you see them? In PaperUI? Have you added those MiFlora sensors from the inbox? Also, could you please let me know if you’ve updated firmware for them? If you just received them from an online shop, most likely they are running an old firmware that does not advertise any meaningful data.


(Markus S.) #394

Hi.
Yes the firmeware is 3.1.8.
And i can’t see them in the PaperUI.
Yes i have added it from the inbox.
In the old installation on raspberry, first time i saw only one channel of the four, changing. And after some changes, i don’t know what i have done, all four were there.
But now nothing.


(Vlad Kolotov) #395

@Master79, PaperUI thing has a bug that is preventing adding dynamic channels for your things. Try to refresh PaperUI page (hit F5 :slight_smile: ).

Also, double check if your sensors are “Online” and the “Discovering control” is enabled for your adapters in PaperUI.


(Vlad Kolotov) #396

Just bear in mind, all those channels are “dynamic”, this means they will be appearing in your “thing” when the device actually advertise them. This normally happens after 20-30 secs. In other words, you won’t see the dynamic channels right after you’ve added a device from the inbox, you will need to wait a bit.


(Markus S.) #397

I understand. But the problem is on the old installation all runs. If i disconnect the raspberry and change to the nuc it doesn’t work.


(Markus S.) #399

Yes to all. I have installed it like it is shown in your description.
+

 <!-- allow users of lp group (printing subsystem) to
       communicate with bluetoothd -->
  <policy group="lp">
   <allow send_destination="org.bluez"/>
  </policy>

  <policy user="openhab">
    <allow send_destination="org.bluez"/>
  </policy>

  <policy context="default">
    <deny send_destination="org.bluez"/>
  </policy>

</busconfig>


and after this a can see the adapter and the devices.


(Vlad Kolotov) #400

Right, so it is a different problem. Can you confirm that on your “Nuc” the devices (MiFlora) stay “online” (even after 30 secs - default timeout threshold)?


(Markus S.) #401

Yes, every 10 seconds i get a update of the last update channel.


(Vlad Kolotov) #402

Very strange then. Can you pls clarify what version of the OH you are using (both on RPi and NUC)?