3rd Party Bluetooth Binding. Beta testers needed

bluetooth
binding
Tags: #<Tag:0x00007fd317598d90> #<Tag:0x00007fd317598b88>

(Markus S.) #423

It works. Perfect.
But the Version is still 5.37. Restart the daemon service get it.
So much thanks to you for helping me this night.
Now we have 4 a clock in the morning and i can go happy to bed.:slight_smile:


(Vlad Kolotov) #424

Perfect. I’m 12h ahead, so it is daylight for me here.


(Thomas Bail) #425

One STep done and then get stuck. I am working still on the extending of bluetooth range,

Now i installed usbip (drivers are part of the linux kernel) on my raspi and bound a usb device on usbip -> works like a charm.

Then logged in at my client raspi and let me show the boud usb device on the server side - yeap is working als well and now i try to attach des usb device and get an error that i cannot resolve. maybe someone is so kind and tries usbip on his system and give some ffedback.

Thanks
Thomas


(orzech) #426

Hi @Fredrik_Andersson, how long are you using nut mini? I’ve been using it for a month and second tracker stopped working - even battery change didn’t work (don’t beep). Did you have similar issue.
Does nut 3 working as presence detection after pairing?


(Fredrik Andersson) #427

I have been using my trackers for months 2-3. One failed before that like you describe. But that one had a lot of corrosion from water. So I was not that surprised.
I think you can use the Nut 3, but it will probably start beeping when you remove it from the zone. I have one. So I can test it.


(Vlad Kolotov) #428

Hi @Fredrik_Andersson, @orzechszek, I was wrong saying that Nut2 cannot be used for tracking. It can be, if you do not enable ‘Connection control’ . Nut2 always advertise something if not connected.


(Philip Knowles) #429

Win10 64.
Using a BLED112-V1 with the Bluegiga binding. Set it to look for COM5 and it found it.
I have a cheap Alcatel C1 which it found straight away but it keeps on finding random generic devices but the IDs don’t match any of my devices. I presume that the ID is the MAC address (but the documentation isn’t clear). My Lumia 640 LTE is Bluetooth 4.0 but it doesn’t seem to find that (either in ‘discovery’ mode or not).
The openhab.log has loads of ‘stale’ devices and timeouts and retries followed by a governor failure - away at the moment but will post part of the log tomorrow.
Any ideas?


(Philip Knowles) #430

These are the repeated errors I get every 15 seconds
2018-04-25 21:47:01.406 [WARN ] [r.transport.bluegiga.BluegigaHandler] - Timeout received while calling simple procedure: BlueGigaConnectionStatusEvent. Trying one more time
2018-04-25 21:47:01.406 [WARN ] [impl.AbstractBluetoothObjectGovernor] - Error occurred while updating governor: /88:6B:0F:66:E4:A1/B0:45:19:CF:30:16 / 70a5137b : Could not initiate process: BlueGigaConnectionStatusEvent / WRONG_STATE


(Vlad Kolotov) #431

Hi @pmknowles, could you please clarify what are you trying to achieve? Presence detection with your phone? If so, do not enable “Connection control”, keep it disabled.

This is actually strange that it tries to establish a connection to your phone. How is your phone detected? As a “generic” or “ble” thing (check UID of your thing, should be something like “bluetooth:ble:XXXXXXXXXX” or “bluetooth:generic:XXXXXXXXXX”)?


(Philip Knowles) #432

I’m getting these messages too.
2018-04-25 22:18:49.681 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/0F:D0:03:5A:8F:61
2018-04-25 22:19:04.324 [WARN ] [r.transport.bluegiga.BluegigaHandler] - Timeout received while calling simple procedure: BlueGigaConnectionStatusEvent. Trying one more time
2018-04-25 22:19:04.339 [WARN ] [impl.AbstractBluetoothObjectGovernor] - Error occurred while updating governor: /88:6B:0F:66:E4:A1/B0:45:19:CF:30:16 / 58215b2b : Could not initiate process: BlueGigaConnectionStatusEvent / WRONG_STATE
2018-04-25 22:19:04.339 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/f8:b8:02:05

The Alcatel phone is seen as BLE but these devices appear as generic. Am just trying to achieve presence detection


(Philip Knowles) #433

Is that Initial Connection Control in the Bluetooth Binding?


(Philip Knowles) #434

Turning off Initial Connection Control seems to have stopped the Governor error


(Vlad Kolotov) #435

Hi @pmknowles, how do you add devices (things)? From the OH inbox or manually? This is strange that your alcatel phone is detected as ble. It is supposed to be detected as “generic”.


(Philip Knowles) #436

They appear in Inbox
getting these in the log now
2018-04-25 22:26:25.232 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/2A:93:FC:AF:4A:A6
2018-04-25 22:26:25.232 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/0F:D0:03:5A:8F:61
2018-04-25 22:26:25.247 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/B0:45:19:CF:30:16
2018-04-25 22:27:25.305 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/2A:93:FC:AF:4A:A6
2018-04-25 22:27:25.305 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/B0:45:19:CF:30:16
2018-04-25 22:27:25.305 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/0F:D0:03:5A:8F:61
2018-04-25 22:28:25.369 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/0F:D0:03:5A:8F:61
2018-04-25 22:28:25.369 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/2A:93:FC:AF:4A:A6
2018-04-25 22:28:25.369 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/B0:45:19:CF:30:16
2018-04-25 22:29:25.459 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/0F:D0:03:5A:8F:61
2018-04-25 22:29:25.459 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/2A:93:FC:AF:4A:A6
2018-04-25 22:29:25.459 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/B0:45:19:CF:30:16
2018-04-25 22:30:26.821 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/0F:D0:03:5A:8F:61
2018-04-25 22:30:26.821 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/B0:45:19:CF:30:16
2018-04-25 22:30:26.821 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/2A:93:FC:AF:4A:A6
2018-04-25 22:31:26.886 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/2A:93:FC:AF:4A:A6
2018-04-25 22:31:26.886 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/0F:D0:03:5A:8F:61
2018-04-25 22:31:26.886 [WARN ] [ager.impl.CombinedDeviceGovernorImpl] - Possible stale object detected: /XX:XX:XX:XX:XX:XX/B0:45:19:CF:30:16


(Philip Knowles) #437

The information below was also pre-filled in in the Inbox
ALCATEL ONE TOUCH POP C1
BLE enabled Bluetooth device
This thing is used for newer versions of Bluetooth devices which supports BLE technology. All binding features are supported by this thing.


(Vlad Kolotov) #438

Looks like you’ve set up the binding to refresh devices every second?

Check “Bluetooth devices update rate” setting. It is not recommended to have it less than 5s. I’d recommend to leave it as is, e.g. 10s.


(Vlad Kolotov) #439

It is first time I see that a phone is detected as “ble” device, your phone is unique :). Anyway, just leave the “Connection control” disabled.


(Philip Knowles) #440

No the update rate is unchanged at 10s


(Vlad Kolotov) #441

If the binding detects presence correctly, those messages are normal and can be ignored.


(Vlad Kolotov) #442

Ok, strange. How many adapters have you connected?