433 Mhz Transmitter / rcswitch-pi


I´m actual trying to get my Raspberry working with some wireless sockets.
For that, i followed this tutorial: LINK

The problem is, it wont work.
Currently I´m stuck at the rcswitch part.

After sending the command, nothing happens. (the socket is ok, I tried it with the original remote.
wiringPi and rcswitch are both installed without a error.

Raspberry 3 with Openhabian
Aukru 433 Mhz Transmitter
Brennstuhl RCS 1000N remote switch
please see the setup pictures below

I tried different Transmitters and different kinds of the antenna.

My command:

[18:17:43] openhabian@openHABianPi:/opt/rc-switch/rcswitch-pi$ sudo ./send 11111 1 1

I´m totaly stuck at this point…maybe someone else has an Idea?

Hey Klumpstein,

I am no expert but as I gathered some information about the 433 Mhz exec binding I found something.
The tutorial shows the solution with exec 1.8 or 1.9 under openhab (the old one). The new openhab works with exec binding version 2.0 and the solution from the tutorial doesnt work anymore. Here are some links about workarounds but I couldn’t make mine work.


As far as I know there is no simple solutioon/tutorial yet.




If you have an arduino i will try first to capture the signal protocol and pulselength with the receivedemo example given with the rcswitch library. After you can try to reproduce it with a send example still with an arduino. If you succeed take these parameters and try to reproduce it with the pi.