A sad story of ZWave and Secure Inclusion

As you might have gathered from the title, this is a sad story.

I’m an active home automation person. I regularly read and contribute to this forum, and even do professional installations of OpenHAB in home and offices.

I have secretly always struggled with secure inclusion. It has never been a big deal, since up until recently it has only been specific to entry control devices. Now it’s everywhere (and should be).

I’ve also cleverly been able to hide behind the excuse that OpenHAB hasn’t really supported it. So when I heard through this forum that there is an experimental update to the ZWave binding that supported secure inclusion, I was very happy. I downloaded it immediately, paired my smart lock… and, failed.

Next ensued 4-5 months of utter infuriation. Every day after work I would sit with my lock, my Raspberry Pi, and my Aeontec ZWave dongle. I reset, I unpaired, I replaced, I trawled through debugging logs and error messages. To no avail. It would not work.

I searched for hours on this forum for people experiencing the same issues. Whilst many people had issues, they were all unrelated, and most of them ended up being rectified. I was tortured by people retelling how they just reset their dongle and tried again!

I made a post of my own, searching for help. Again, nothing. It was getting unbearable.

In the end, I decided enough was enough, I’m moving my entire project to Home Assistant. At this point I started Googling for Home Assistant secure inclusions, to make sure it was supported.

…The result was troubling. I found a topic on their forum, and started reading. There, plain as day, was some miraculous individual making the statement below:

The button on the Z-Stick is great for quick exclusions, but only performs regular, non-encrypted inclusions.

If your device supports the S0 Security CC, make performing inclusions over USB a habit.

You are supposed to pair inclusions over USB.

You are supposed to pair inclusions over USB.


… It worked perfectly.

I cannot believe this is not mentioned anywhere? Where can we make this clear so that no one will ever have this problem again?

It’s always good to read the binding documentation :wink:

1 Like

Yeah. I would have read this when I started with secure inclusion, but I think it just never jumped out at me until it was put in terms like “over USB”.