Absolute Newbie: trying to add bindings

  • Platform information:
    • Hardware: Raspberry Pi 3 Model B
    • OS:Raspian GNU/Linux 11 (bullseye)
    • Java Runtime Environment: JDK 11
    • openHAB version:3.2.0
      Following example in the documentation, trying to install bindings for Philips Hue (not my ultimate goal but seems like a good place to start). On the web interface, settings → add-ons → bindings presents, instead of a single column of a couple hundred items from which “Hue” is searchable per the documentation, get a 3X4 display with option to “show 19 more”. None are of immediate interest. Seems as if repositories need to be installed, but no explanation I can find as how to accomplish this. Did apt updates, and all updates available in openhabian.config.

Hey @liguorid, under settings → add-on management (right column under “system services”), is “access remote repository” set to on? I have never changed this setting - must have been on by default for me - but just came across it and it seems like a good place to start.

Normally you don’t need to configure an additional repository, if you want to add standard bindings.

There are two ways to install bindings:

  1. as you described through the add on page: settings → bindings → than there is a search button in bottom right corner

  2. of through the thing page: settings → thing → + icon to add a new thing → install binding

1 Like

Are you looking for this binding?

image

Does it not appear in the list under myserver:8080/settings/addons ?

Hi, thanks for the suggestions. Yes, enable remote repositories is turned on. I tried turning on a couple of other off by default settings such as "json 3rd party add on service and “community marketplace->show unpublished entries”. I get warnings they could damage my system. But nothing changes what I see under “settings-> add ons->bindings”. Is there a way to attach a screen shot here? What I see is nothing like I’m supposed to see.

No, it does not.

Your 3 x 4 grid with the show 19 more are the marketplace bindings that are available via a different mechanism than all the built-in bindings. The fact that you don’t see the list of built-in bindings suggests that there is some reason your system cannot collect that information.

Do you see any errors in the log files?

Anything in particular I should be looking for? In var/log/openhab/openhab.log I see, at the very end:
2022-04-12 22:00:16.158 [ERROR] [ore.karaf.internal.KarafAddonService] - Exception while querying feature ‘bindings’
I also see warnings, some related to “karaf”. No clue what to do about any of them though.

As Justin says, something is not right with your installation, because you’re not seeing the official
“openHAB Distribution” bindings. Rather than trying to fix it, I would suggest starting over, because there may be other things that aren’t working.

Are you running other programs on your RPi, or dedicating it to OH? If so, I strongly suggest using the openHABian image to get up and running quickly.

At this point Russ’s solution to attempt a reinstall is probably your quickest path to get up and running; especially since it seems that you won’t loosing much in the way of a configuration at this point.

If you want to dig deeper and see if you can solve this particular problem then we need to look a little deeper into those log errors and warning.

The best way to put log entries (or any sort of technical code that you want other uses to be able to read) is to use code fences. Just hit the </> button on the post formatting bar and paste all your suspicious log lines where it says paste here. Don’t worry if it looks like too many log lines; it’s better to post them all and lets others sort through than to not give us enough information.

1 Like

Yes, I used the openhabian image, dedicated RPi. I am considering reinstalling, even though some people say doing the same thing and expecting different results is the definition of insanity. I can blow it onto a fresh SD card so I wouldn’t be losing anything even if there were something important.

In addition to the plain text file in the …/log/openhab/ directory, there were several gzipped files–not surprising considering the amount of stuff that goes into the log file even when you’re not using it. I may try unzipping the oldest one–should cover immediate post installation if not installation itself–and seeing if there’s anything suspicious I can post here.

Even if I do the same thing and get the same results, at least I’ll have fewer log file entries to deal with. I’ll make sure the RTC is set in openhabian-config (it wasn’t at first but I think I know why) then keep track of what I do when and see what log entries it generates. I’ll let you all know what I try and what happens. Thanks for all the good suggestions.

That doesn’t entirely apply here, because you’re not in full control of what happens when the image expands and sets itself up. Software’s kind of a pain that way.

Make sure to leave it alone for awhile after the first boot. It’s been a long time since I re-imaged from scratch on an RPi3, so I don’t recall how long it takes, but I think the docs say to leave it for 45 minutes. It’s possible that jumping into the web interface too quickly impacted something.

If you run into the same issue again, I can try installing on my RPi3 to see if I can replicate. I won’t be able to do that until next week at the earliest.

OK, so I did the same thing in general, different in detail, and got different results: instead of getting a dashboard with only a few bindings to add, I don’t get a Web interface at all. Firefox says “cannot connect”, Google Chrome and MS Edge say “connection refused”. Same IP address as SSH, which does work, using port 8080. I had let the installation run and didn’t touch it for over two hours.

Differences in detail: used a newer Openhabian image, used Etcher instead of Raspberry Pi Imager, used Windows instead of Linux.

This result is actually the same as I got using a Raspberry Pi 1B: no HTTP connection whatsoever. But I figured the Pi 1 is too old to be supported, so I freed up the Pi 3B instead.

I’m at my wit’s end trying to get to square one with this thing.

The differences in detail, for what they’re worth: I dual boot my PC, using Linux whenever possible, Windows when needed. Somewhere in the Openhab installation instructions I read that it automatically (somehow) picks up your local settings for setting the time. This has never happened. Linux uses UTC plus local offset to set the time, Windows uses something else (in the computing world there is the right way, the wrong way and the Microsoft way). It turns out to be easier to teach Linux to play nice with the shared time clock than Windows, and thought that might be the issue for the time zone setting, so I used Windows to burn the image this time. But no change. I really don’t care as long as it’s settable later in openhabian-config–unless it in some weird way is screwing up the install.

As of a few hours after installation, there is nothing in /var/log/openhab except an empty Readme.txt.

That’s really weird. The clock shouldn’t make a difference.

I’m away until Tuesday, but I’ll try installing on my 3B to see if I get the same results.

Are you using wifi or Ethernet?

Ethernet. Weird indeed.

Did the install one more time. This time, used a different machine to burn the image. Plugged in a monitor and watched the console output for the whole thing. Everything looked OK. Opened up the web page and everything functioned according to how it’s supposed to. Installed the Hue binding, Oppo Blue Ray player binding, and a few others that I thought might be useful. It discovered my Hue hub and my UDP205. At this point I don’t know how to actually go about controlling these things through OH but at least now I can start learning. For another day, though.

A microporcessor is a deterministic machine, and to do exactly the same thing and expect different results would be truly insane, only it’s hard to know if you’ve done precisely the same thing. I know that for troubleshooting purposes it’s best to change only one thing at a time, but at this point I’m just happy to be up and running. The other machine is also the same Ubuntu/Windows 10 dual boot configuration so that isn’t it after all. And Etcher does a verification, which you can skip if you want to, but I don’t. Presumably there’s a SHA signature inside the .gz. I really can’t think of anything using another machine would have accomplished, but there it is. Also, in order to be able to plug into the HDMI port for the monitor I used a different Ethernet port on my switch, with a different cable. But it was completely reachable via SSH always, and HTTP sometimes, using the original port and cable.

I have enough to learn without going back and doing forensics. But if anyone is keen to, I still have the original SD card I used before everyone suggested I do a re-install, any of whose contents I would be happy to upload upon request. For now, thanks for all the suggestions and it’s good to see there is a community here for help. I’ll probably be needing it again.

2 Likes

Good stuff. I was more concerned that something might be wrong with the openhabian image with respect to an RPi 3B.

So, this is interesting. I went to add a binding today, and the “openHAB Distribution” section is missing. It was there a few weeks ago when I uninstalled the TP-Link binding in order to add the beta version from the marketplace. I haven’t made any changes to my system since then, beyond items and rules. It’s just gone, and I suspect that it’s the same thing that happened to you.

The only thing I can think of is that I had a power outage recently, but my UPS should have executed a proper shutdown. I don’t have time to look into it right now, but I guess I’ll be doing some more investigation on this.