Activating OH2 Addons

  • Platform information:
    • Hardware: x86_64/
    • OS: Fedora Core 27
    • Java Runtime Environment: openjdk 1.8.0
    • openHAB version: 2.1
  • Issue of the topic:

I want to debug some issues I’m having with the lutron binding (keypad not working), and have installed the development environment through the Eclipse Installer.

It seems to install ok, and I can run the demo system. However, I can’t work out how to get it to load the lutron addon. The Add-Ons tab in the PaperUI lists around 10 bindings with cryptic 5 letter names (seemingly random letters).

Adding an explicit Thing for lutron:ipbridge:radiora2 as shown in the docs has no effect. The binding is silently ignored.

I do see one m2e build error in the IDE, which I’m assuming is the problem:
“Plugin execution not covered by lifecycle configuration: org.commonjava.maven.plugins:directory-maven-plugin:0.2:highest-basedir (execution: directories, phase: initialize)”

I tried a full re-install just in case something went wrong there, with identical results.

Is the m2e error related to the missing add-ons ? If so, what is the correct way to fix it ?
If the m2e error isn’t really an issue, how can I update the config to pull in the lutron binding ?



Ok, I’ve eliminated the m2e error by adding the following to my eclipse lifecycle-mapping-metadata.xml:

                <execute />

I’ve no idea whether this is the right thing to do or not as maven is a completely new concept to me, but the error has now gone away.

However I still see the same problem when I run the resulting build - Only 10 bindings listed in PaperUI, all of which seem to be 1.0 bindings. None of the OH2 Addon bindings show up.

Any idea what I’m missing ?



In the development environment, the binding selection in paperUI does nothng. It is filled with dummy data. To include a binding, you need to select it from your workspace in the run configuration.