'Add as Thing (with custom ID)' not working properly in OpenHAB 3.2.0M3


I found a strange problem when adding Things with OpenHAB 3.0.1.

As far as I accepted the default ids (i.e. by clicking on the ‘Add as Thing’ option in the Inbox) everything worked fine: the Thing is added to the list of installed Things and removed from the Inbox. Now I decided to use more readable ids for my Things and I observed a strange behavior: if I add Things using the ‘Add as Thing (with custom ID)’ option, the Thing is added to the list of Things with ‘somehow’ the id I chose but also remains in the Inbox.

This is the menu of the Inbox with the options I’m referring to:

I say ‘with somehow the id I chose’ because, if the default name of a Thing is say ‘zwave:device:Everspring:node14’ (I named my ZWave stick ‘zwave:device:Everspring’, this is the reason why it prefixes my ids with ‘zwave:device:Everspring’ I guess), when I add a Fibaro Smart Implant and choose ‘Add as Thing (with custom ID)’, the UI asks me what I want in place of ‘Everspring:node14’. If I write X the final id will be ‘zwave:fibaro_fgbs222_00_000:X’ and not ‘zwave:device:X’ as I expected.

Fibaro Smart Implant here is just an example, I guess the same happens with all other types of Things, maybe even with non ZWave things. For example I also tried with a Qubino Smart Meter which will be named ‘zwave:qubino_zmnhtd_00_000:Y’ and not ‘zwave:device:Y’ as expected.

Here what I have after trying what I described above:

And this is what remains in the Inbox after adding Node 14 and Node 21 by using the ‘Add as Thing (with custom ID)’ option:

Is this a bug or am I doing something wrong? Has anyone else had the same problem?

Can someone help me?

Hello, after many months and many updates (I’m now at version 3.2.0M3) I tested this behavior again and nothing changed from the first time I noticed this problem and reported it. Just to be sure, a few days ago I restarted everything from scratch, excluding all my devices from the ZWave network, hard-resetting the ZWave controller, removing the controller too and then re-binding my devices from scratch. Same problem as described in my previous posts.

During the past months other problems related to this ‘Add as Thing (with custom ID)’ feature were fixed (for example, now it only allows modifying the last segment of the ID, previously the last two segments could be modified, and this caused problems) but the issue I found has never been fixed.

Can anybody replicate this issue, please?

I submitted an issue in github (openhab / org.openhab.binding.zwave) but it did not receive any reply since last May, so I guess this is not the right place where to report bugs (sorry, I’m pretty new in OpenHAB, so I don’t know the way to proceed in these cases).

I’m starting to lose hope that this problem will ever be solved, so now I don’t know if to still wait for a solution or simply forget this ‘Add as Thing (with custom ID)’ feature (which I liked a lot, or would like a lot, if it worked)…

Just to resume (also because the first post is no longer completely valid, since now only the last segment of the ID can be modified): if I discover a new ZWave Thing and:

  1. add the Thing immediately by clicking on the Thing when it is discovered, everything works fine (with default ID)
  2. after discovery I go to the Inbox and add the Thing by using ‘Add as Thing’ option, everything works fine
  3. after discovery I go to the Inbox and add the Thing by using ‘Add as Thing (with custom ID)’ option, but I do not change the default ID, everything works fine
  4. after discovery I go to the Inbox and add the Thing by using ‘Add as Thing (with custom ID)’ option, but I change the default ID (only last segment), the Thing is added to the list of registered Things but it also remains in the Inbox. If I delete or ignore the duplicate from the Inbox, it reappears from time to time, for example after a reboot

Moreover, if I use an ID that is already used by another Thing, the two Things mess up… It seems that there is no check that the ID is not already used!


I agree with Frank : still a mess in this function :wink: ! I suggest

  • UI update to only allow the last segment modification
  • existing thing control with user request to know if he wants to delete the previous thing or to override it (keeping the former configuration, to be sent again to the physical device)

Not a zwave expert, but with my limited background and IMHO, the “add as thing (with custom ID)” should not even be available with the zwave binding. “Maybe” the “device” can be replaced (although I’m not sure), but the third section has to be the zwave bridge ID and the “node” is assigned during the discovery scan, so I don’t that be changed from the Inbox either.

What can be changed is the label. I use that to better describe the thing.
Screenshot 2021-12-17 151404

My two cents.


If the custom ID (only last segment of course) cannot work with ZWave devices (because of the way ZWave controller works etc.) then I think this feature should be disabled in this case.