Add VRCZ4 variation to database


I have a few Leviton VRCZ4 devices in my house and I managed to add some of those to my installation; however, I am unable to add the other ones. This problem happens because VRCZ4 has at least 2 different models (depending on your region), and only 1 is in the database. I found some useful answers on the HomeAssistant forum (links below), and they worked for me in HomeAssistant, but I don’t know how to do these changes in openHAB (just getting started…). What I did there is copy the configuration files for the working VRCZ4 and just add the model of my variation.

From what I read up to now, I need to add my device to the public device database, but I’m not quite sure how to proceed since everything is the same, except for the Device’s ID 0702:0209.

So, summarizing, I have 2 questions:

  • How do I add the device to the database so other people can use it?
  • How can I add the device to my installation without having to wait for another OH build?

Thanks for your attention!


HomeAssistant links:

There is no easy way to do that but, unlike Home Assistant, we have a community maintained database as part of the binding. If you wist to add this device you can start looking at the Database guide.

Otherwise we can assist. The mode useful information to start would be the xml file generated by openHAB usually located in the /var/lib/openhab2/zwave folder.

1 Like


I checked the database and it seems that my device is already listed.

I then took a look at the /var/lib/openhab2/zwave and saw that this specific zwave node does not have a XML file. I already tried removing and adding it back to the zwave network, but I got no luck. The UI says that the initialization is not complete, and keeping my controller close to the VRCZ4 for hours did not help.

Do you have any idea on what my problem may be?



The xml file not existing means the binding has not fully discovered the device. Unlike Home Assistant device discovery does not need to happen when first included into the network. If that is a battery operated device it may need to be waked up many times to complete this discovery.

The official binding documentation shows how to collect debug logs so the developer here can troubleshoot further.

1 Like


Thanks for all your help Bruce! I activated the debug log re included the device. To do this, I removed node 18 from the controller, factory resetted the device, and included it (now under Node 22).

I saw that the log says that some transactions were cancelled/time out, and that there is a line saying “No data from the device”. Any ideas on what may be causing this?

I have attached the log here:
zwave.log (732.0 KB)

The device is not responding to the version requests which the binding sends. The device states it supports the version command, so the binding needs to find out what versions the device supports.

The binding sends these GET requests to get the version -:

The device should (ie MUST) respond with the version report, but this is not received by the binding. The transaction times out so the binding tries again.

The ZWave requirements states -:

Note -:

The Version Report Command MUST be returned in response to this command.

Which does not appear to be happening.

We can work around this by forcing the version with a database option FORCEVERSION which needs to be added to the options field in all command classes for this device.

1 Like

Hi @chris,

Thanks for your help!

So, from what I have read I need to add the FORCEVERSION option in the public database, right? Just want to be sure so I don’t mess anything up…

Yes, that’s correct. Since the device doesn’t seem to respond to this request at all, it will need to be done for all command classes.

Ok! Did that. Do you know when the update will reach my OH instalation, and whether I need to reinclude the VRCZ4?

Chris updates about once a week After that a new snapshot binding is built. You can then use an install script to manually install in OH.
You then need to delete the Thing (NOT exclude) and rediscover it to get the new binding changes. It will have the same ThingId so your Items will still be correct.


1 Like