Adding a new z-wave device to device database

I’ve a remote controll MTN5051 from Schneider - Merten (Se her). It’s quite nice device since it has both IR and z-wave but it’s not i device database.

I’ve tried to add it follow the info from opensmarthouse but I’m really unsure. I used the configuration file from openhab but its does exactely match all commands I found in z-wavealliance website.

When I look to the logs I only see reaction for one button. So I have the imoression that most button/command is not matched

19:58:53.847 [DEBUG] [ing.zwave.internal.protocol.ZWaveNode] - NODE 4: Incoming command class COMMAND_CLASS_SWITCH_ALL, endpoint 0
19:58:53.847 [DEBUG] [ing.zwave.internal.protocol.ZWaveNode] - NODE 4: SECURITY not supported
19:58:53.847 [DEBUG] [otocol.commandclass.ZWaveCommandClass] - NODE 4: Received COMMAND_CLASS_SWITCH_ALL V0 unknown command 5
19:58:53.847 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 4: Commands processed 1.
19:58:53.847 [DEBUG] [rnal.protocol.ZWaveTransactionManager] - NODE 4: Checking command org.openhab.binding.zwave.internal.protocol.ZWaveCommandClassPayload@365cdaa2.

Welcome to the community!

Add 12 association groups (#1-#12) and 12 parameters (#1-#12) to the device definition in the Z-Wave database. Limit the values of the 12 parameters to 1=On/Off and 2=Scene, then Request Review, wait for a new Z-Wave Binding snapshot, install snapshot, test your device.


Thanks ! I’ve just sent to review.

Just to understand what I’ve done: how Parameter, association group and endpoint works?

Please read Z-Wave Primer — SmartThings Documentation 1.0 documentation.

Adding the association groups to the device definition in the Z-Wave database should enable the openHAB user to associate Z-Wave devices to the Z-Wave buttons of the remote control.

Adding the configuration parameters should enable the openHAB user to change the functionality of the buttons (1 = control of associated Z-Wave devices, 2 = ? - but we will find out by watching the debug log …).

As of Feb 2019, COMMAND_CLASS_SWITCH_ALL was not implemented in the Z-Wave binding, cf. How to issue a ZWave COMMAND_CLASS_SWITCH_ALL - #8 by chris.

Ok, I succeeded to add my device to database and update the binding to last snapshot.

I still have no channel (which seems to be normal) but I didn’t manage to associate a a group to a device. To what I’ve seen in the logs, I have some problems with initialization:

14:37:12.315 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 4: Starting heal on node!
14:37:12.316 [DEBUG] [ing.zwave.internal.protocol.ZWaveNode] - NODE 4: Can not start heal as initialisation is not complete (REQUEST_NIF).

I can’t find the right configuration

14:41:53.264 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 4: Configuration update set config_1_0 to 1 (BigDecimal)
14:41:53.265 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 4: Error getting configurationCommandClass

the association does not work either…

14:42:47.999 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 4: Configuration update set group_1 to [node_9] (ArrayList)
14:42:48.000 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 4: Association 1 consolidated to [node_9]
14:42:48.001 [DEBUG] [nding.zwave.handler.ZWaveThingHandler] - NODE 4: Unknown association group 1

I don’t really know to go further :-/

The only way to get the remote to send a NIF seems to be to (re)include it (see manual, p. 21). Try to keep the remote awake by pressing some keys during the inclusion - pure speculation, the manual is too bad. Merten is known for twisting Z-Wave terminology beyond recognition …

I’ve (tried ?) exclude the device, but I can reinclude it :-/ The manual is not very clear either. “Press the [Z] key.” and “Press the [Conf] key 3 times” in page 9 and "Press and hold the [Z] key + press
the [Conf] key 3 times: " in page 21. None works tough.

Is thery any way to ensure that a device has been truly exclude for a network ?