Adding Aqara Vibration Sensor to Zigbee

I’ve added the Aqara Vibration sensor using the ZigBee binding for a CC2531 plugin, and its coming in as the right device (Lumi vibration aq1) on PaperUI, but the channel is coming across as ‘Door Lock State’ with an on/off switch - rather than any parameters around vibration.

Needless to say, I’ve tried re-adding quite a few times to reach the point of posting this.

My other ZigBee devices work fine (Aqara door sensor, Ikea Remote, Centralite door sensor, Aqara humidity/temp) and I appreciate adding these Aqara things can be a pain, but I know what to do and its worked fine. Just this device brings up the wrong channels.

Don’t want to head down the MQTT route, as I’m looking to keep things as simple as possible.

Any advice ?

Rgds
Shaun

  • Platform information:
    • Hardware: Rpi
    • OS: Openhabian (all updated to latest as of 19/08/2020)

Hey Shaun,
As a Home Assistant & deCONZ user, I just had a very similar situation - so it’s probably the sensor itself. While my vibration sensor showed up fully functional, it had an additional switch (Door Lock, as yours) which is not there usually. I tried at least 10 times to re-pair it without success.

My Solution was to unpair it from the Zigbee coordinator (& remove it everywhere it’s mentioned in Home Assistant - including the strange light switch). Then I pressed the button on the sensor for 10 seconds, took the battery out, pressed the button for 10 seconds again. Afterwards I re-paired it with the Zigbee coordinator and the bug(?) was gone! :smiley:

Unfortunately that didn’t work, but thanks anyway. Its still only reporting the Lock state. I appreciate adding these devices is a challenge, but I’ve done the Temperature/humidity and door sensor without problem and they’ve maintained a rock-solid connection, in spite of all the fettling to get the Vibration one working. Also have a problem with the Magic Cube, but that’s just a nice to have at this stage……….