Adding new device or amending exiting device in CD Jackson DB?

Tags: #<Tag:0x00007f4335b5adb8>

New to this forum so HI and thanks for the help I have gleaned from reading it in the past.

I have a Everspring motion sensor SP817. However nnly the Sp 816 appears to be in the Wave binding DB. Although I have been using Openhab2 quite successfully for a while now I am new to this part of the process. I have registered on the Device DB website, and as per the instructions I have raised a ticket but I heard nothing back about my access. I am now not sure where to chase. Does anyone else have the Everspring sp817 (I got this is in the UK) and is about to update it in the DB list , or can someone point to me to how to get my access granted and I can explore how I get it updated ?
Openhab seems to have created a network node XML for it so I assume that is all that is needed progress?

atsrus

I can’t find any reference to a ticket - when did you raise it (and where?).

There are instructions for adding devices here -:
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-database-guide

At the moment it’s a little hard to say what is needed without knowing a bit more about the device, and what type/ids it has. What is the difference between the 816 and 817?

Thanks for prompt reply. This was the ticket number I raised, maybe I have not done too the correct way !
Ticket ID:PXdCHxTRhwW

Ive not experience of the sp816 but it looks like it is an outdoor version. sp817 is an indoor version, and looks remarkably similar in terms of functions etc… The the id’s it shows in Openhab are

 <version>4</version>
  <manufacturer>0x60</manufacturer>
  <deviceId>0x6</deviceId>
  <deviceType>0x1</deviceType>

Does this help.? I can upload the XML if necessary.
Thanks

I’m not sure why I didn’t find that, but anyway, I’ve got it now, and have updated your access.

Probably it is best to create a new device in the database.

Thank you very much for your prompt response again. I have uploaded the XML. I encountered some SQL error in the process but it looks ok now. I have a filled in as many of the fields that it said were still in error due to missing info such as inclusion and exclusion. But I do not have access to an uploadable PDF manual for this one. It does not seem to be available at present easily. How can it be progressed. Obviously if I find one later I will add it? What happens now and how do I get access to a working DB entry now for this device ? Tks

@chris: I saw the same when I made my one

@atsrus01: So I think it can be ignored from us (users). but maybe Chris would need to have a look at the process.

Cheers
Stefan

So Chris, is there anything else I need to do to get this device online and usable now, its still awaiting a PDF manual that I cannot supply ?
https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1028

Tks
atsrus01

Do you have a scanner, or can you take a photo of the manual that came with it? If so, please format it as a PDF and upload that - at least it provides some reference, and avoids me having to find some way to bypass the checks in the database :wink:

Yes Will do. Not sure how the copyright works in that case though.
reds

For this one the original manual seems to be listed on the ZWAVE alliance website
http://manuals-backend.z-wave.info/make.php?lang=de&sku=SP817-2&cert=ZC10-17105825

check it

tks for that. Looks like a slightly diff version ( i.e -2) probably just regional and seemed to be in mixed languages ! .

However, Chris , I have scanned and PDF’d mine now and uploaded to the device DB so hopefully its ready to go.

Tks
Rgds
atsrus01

Chris,
I have done all I feel competent to do on this device entry now. Any further and I would need some help from people. Is this is a position it can be progressed now ?
PDF uploaded and classes updated.

https://www.cd-jackson.com/index.php/zwave/zwave-device-database/zwave-device-list/devicesummary/1028

Thanks

Thanks - I’ve updated a couple of things - if the motion detection doesn’t work, please let me know…

Otherwise it’s approved and I will do a database update tomorrow.

Thanks.

Thanks v much for that. I think I have worked out how to add the confiuguration parameter information also for this. Ive updated that now also. Hope that does not cause you a problem.

Once this is available , what is the process for me to get the updated device info into my OH2. DO I need to de-install the Zwave binding and re-isntall. Or do some sort of apt-get update(s) on my Raspian Pi.
(And yes of course I will feedback on testing for the good of all.)
Thanks

OK I guess this is not a question for Chris any more since he must get pressd on this sort of stuff continuously. It now seems the device I entered has been accepted/signed off in the ZWave DB/device list. I am unclear as to my next steps on this now. Does it at some point get pushed into another version of the binding ( I seem to have 2.4) and I have to un-install the binding and re-install via the paper UI and at some point will see the new entry? Or does this have to get in a larger release somehow , if so how do I how when this is available and how to get hold of it. tks sorry for newbie questions.
Rgds
atsrus

Yes, you will need to use the latest snapshot of the binding (ie 2.5 snapshot) to get any recent updates.

You can use the following script -: