Adding OH2 thermostat to OH3 model?

Migrated from oh2.5 to OH3 last night. Everything seemed to go good but only 2 of my items ended up in the new “model” section. No problem I’ll just add the others. But my thermostat will not let me set a temperature on the setpoints. It just says “null” and clicking on it takes me to a graph.

The thermostat was part of a text config under 2.5 that seems to have made it thru the migration as the items are still listed and my google home is still able to control them. I tried importing the items but it keeps hanging on the metadata that is needed to translating modes and things into google assistant.

Do I need to change the text config and import it or leave it and make a new item for the model? And what setting am I missing on the model that I can’t control the setpoint in OH3?

Info: OH3 installed via apt
Lubuntu 20.04(64bit) fresh install 12-2020
Zulu java 11
Hardware: samsung xe700t1a
Intel core i5-2467m
4gb ram
128gb ssd/98gb free
thermostat items in item file are as follows

Group g_Housecool   "House Cooling"    { ga="Thermostat" [ useFahrenheit=true,modes="heat=1:Heat,heatcool=3:Auto,off=0:Off,cool=2:Cool"] }
        Number  CoolCurrentTemp " House Cooling Temperature  "          (g_Housecool) {channel="zwave:device:c8787433:node3:sensor_temperature" ,  ga="thermostatTemperatureAmbient" }
        Number  HouseSetTempCool " House Setpoint Cool "             (g_Housecool) {channel="zwave:device:c8787433:node3:thermostat_setpoint_cooling" , ga="thermostatTemperatureSetpoint"}
        Number             Housecoolmode    "House A/C  Mode"   (g_Housecool)  {channel="zwave:device:c8787433:node3:thermostat_mode" , ga="thermostatMode"}

Group g_Househeat   "House Heating"   { ga="Thermostat" [ useFahrenheit=true,modes="heat=1:Heat,heatcool=3:Auto,off=0:Off,cool=2:Cool"] }
Number  HeatCurrentTemp "House Heating Temperature"          (g_Househeat) {channel="zwave:device:c8787433:node3:sensor_temperature" ,  ga="thermostatTemperatureAmbient" }
Number  HouseSetTempHeat "House Setpoint Heat"             (g_Househeat)  {channel="zwave:device:c8787433:node3:thermostat_setpoint_heating" ,  ga="thermostatTemperatureSetpoint"}
Number             Househeatmode    "House Heater Mode"   (g_Househeat) {channel="zwave:device:c8787433:node3:thermostat_mode" , ga="thermostatMode"}

I’m leveraging the OH remote binding to view my thermostat (also a zwave one) and have the following setup that lets me change settings:

As a bonus I also added the following on the slider widget to provide others the ability to change the temp if something on the automation side fails but still keeps it in the desired range.

value: oh-slider-item
  min: 66
  scaleSteps: 1
  max: 72
  scale: true
  step: 1
  label: true
  scaleSubSteps: 1

1 Like

I would try that but I only have the one pc to run OH on. I don’t want to deal with setting up 2 instances on the same machine as I feel it would just create issues long term. (only one zwave dongle for 2 programs and other issues).

Unless I’m completely misunderstanding the binding - it seems to be a way to control a second OH install on another device for backward compatibility with OH1 bindings or extending a network?

The info I posted should be what you need, I was just pointing out that I’m not exactly in the same scenario as your OH.

Updating the metadata is most likely what you want to do and then under Location on my test setup I’m able to see the slider and control the temps.

1 Like

OHHHH I see now - I have to add metadata with the default widget types!
Thank you !

Gonna make widgets for all the things!

Not a problem, it took me a while to figure that out along with correcting state metadata that wasn’t showing up correctly. Since I have the benefit of testing OH 3 while keeping my 2.5 setup on the Pi the same, I’ve been lucky enough to compare and contrast differences and attempt to track down the things I need to account for on the OH 3 side. :wink: