Adding zoneminder monitors to model

hi all! I’m trying to add a zoneminder monitor to my overview page but I can’t get anything to play. I’m completely lost in this. I just want to be able to view my camera on my overview page on the wall-mounted tablet I set up. Which Channel do I even add as a “point”? What widget type do I use?

Info: OH3 installed via apt
latest Zoneminder installed via apt (same machine)
Lubuntu 20.04(64bit) fresh install 12-2020
Zulu java 11
Hardware: samsung xe700t1a
Intel core i5-2467m
4gb ram
128gb ssd/98gb free

Should be the VideoURL channel, and you’ll want to use the Image Card and select the Item for whatever monitor you want(VideoURL) and it should display.


Tried the image card and it just shows a missing\corrupted image icon in the corner.
The video card just displays a message about no source. The camera plays fine in zoneminder. The computer has FFmpeg installed so transcoding shouldn’t be an issue.
I also tried adding the camera thru the IP camera binding with the same results. Adds to things fine but can’t get it to show video in openhab.

It’s working here, but I am running the snapshot version so I’m not sure if something might be broken in earlier version.

You don’t need ffmpeg for the zoneminder binding, as zoneminder is doing all that work. You wouldn’t want to do it twice.

I am using oh3 final.
With the video_url channel and image card it’s working fine.

I’m wondering if it is because I am running ZM on the same machine?
I can load ZM and see the video just fine and openhab says it’s online it just won’t display it.
Wish I had another computer to run ZM on and see if it fixes it.

This seems unlikely.

If you put the url from your video url item into your web browser, do you see the video?

Also, do you have authentication enabled on your zoneminder installation?

1 Like

sorry for the late reply - life happened.
If I put the URL in my web browser it works fine.
I do have authentication on my zm but I have tried with auth turned off.

Ok so another reboot and now it works.
but what widget settings do i use to make it show in the overview page? I have a card in the overview page for it now but it does nothing. I’m trying to set up wall mounted tablets for home control and monitoring and learning things along the way.

You have to use a image widget with the video URL channel

I can’t find that as an option in the page editor. I have that selected for the “standalone widget” in the model. It’s working there. But the card on the overview page does nothing.

This is what I do.

For the overview page? I’ll test it when I get home this evening.

In my case it’s on a separate page where I put the video from all the cameras. I’m far from an expert on the new UI, but I don’t see why it wouldn’t work on the overview page.