Aeotec Door/Window Sensor 7 "SECURITY not supported"

Ok, thanks to a lot of them from a lot of people, the Aeotec Door/Window 7 Sensor is now in the database.

Now, I put zwave in DEBUG logging to check things out and sure enough, things seem to be working. One thing that is puzzling to me is that in DEBUG mode, zwave reports “SECURITY not supported” every time an event happens.

This device is SUPPOSED to have the S2 framework which is SUPPOSED to encrypt messages between the device and the controller.

Is this not happening or does that message mean something else?

TIA for all your help.

Cheers! :slight_smile:

I bet the device is not securely included. Look in Habmin> Configuration> Things> device> Attributes> and look at security. Is there a red X?

Yes. There is a red X by “Security”.


The device is not using security then. The binding is always checking if it should use security to communicate with the device. But if the device is not securely included, you will see the log message that security is not supported. Securely include the device and you will not see that message.

I was afraid of that. Gonna have to ping Aeotec and find out exactly what “S2 Security Framework” means because it does not mean ZWave security, apparently.

Thanks Scott, for your help. :slight_smile:


Just checking, try factory resetting & including again.
They mention including from a factory reset state.
Security flag is set in the database.

Thank you. Will try that right now.


S2 does mean security, but I don’t think the binding supports it yet. But it is backwards compatible, so I believe you can still securely include it. Check the settings for your controller. The default security setting is Entry Control, which may not include your device.

Here is the Factory Reset instructions.

This device also allows to be reset without any involvement of a Z-Wave controller. This procedure should only be used when the primary controller is inoperable.
Once Cover is removed and tamper switch is tripped, push the tamper for 5 seconds until red LED blinks. Then release tamper and push it again for 5 seconds until LED blinks.

Not sure what this means looking at the zwavealliance site.

Found this chrome-extension://oemmndcbldboiebfnladdacbdfmadadm/ but still trying to understand it.


Just curious. What is your zwave controller? Does it support S2?

Ok, I shut the whole thing down, removed the node from my controller using the debug tool, did a factory reset on the switch, brought everything back up, included the switch (new node number) and still no security. but from what I have read, while this is a ZWave+ device and it does have the security framework, as a switch, it will always be “S2 Unauthenticated”?

At least that is what this PDF seems to say

Cheers! :slight_smile:

Now THAT is an excellent question. I can answer the first part, not the second.

My controller is an Aeotec Z-Stick Gen5. Model ZW090-A

it says it is Zwave+

I do not know if this supports S2. I guess I’m off to find out if it does and/or if there is a firmware upgrade for it.

Cheers! :slight_smile:

Short answer, I don’t know. and no firmware upgrades are available for the Z-Stick. I pinged @aeotec on twitter to see if I can get an answer.

Cheers! :slight_smile:


I just got an email from Aeotec

As for Z-Stick Gen5, it is compatible to S2 framework security as this is typically handled by software rather than the Z-Wave USB Adapter. Some softwares that already support S2 framework (may or may not be beta) would be Homeseer HS3 and Z-Wave.ME software.

The Z-Stick Gen5 itself does not handle security directly.

So I guess the answer is no, but it’s not supposed to?

Cheers! :slight_smile:

I read that is it depends on the OH binding supporting it.
We need to wait for @chris to get that answer.

1 Like

The Openhab ZWAVE binding does not support S2 yet. If you set up the controller to use Security (e.g. in PaperUI or HABMIN) then the device should be included with S0 security. This is what happens with any other S2 device as well (e.g. the AEOTEC Nano Shutter).
When I tried to include the Sensor 7 with “security on” last time (a few weeks back) it initially started with recognizing the device as a secure device, but when it was later checking for S2, it switched security off complety, instead of reverting back to S0. I mentioned this to @chris and he was starting to look into this. Not sure, what the current status is. If I find time, I will try secure inclusion again later this week.


Thanks! I learned something new today.

I have set this but it just reports that the device does not require security. Oh well. That’s not the biggest problem I’m having with this sensor.

Thanks for your help! :slight_smile:

After changing this, did you reset the device and reinclude it? Secure inclusion can ONLY be done within 15 seconds of the inclusion, so changing parameters later will not help.

1 Like