Aeotec energy meter (W095) does not send updates

Tags: #<Tag:0x00007f616fd46570>

I have seen this issue in post before and read it. None of them was fixing my issue.


I have an energy meter ( Home Energy Meter Gen5) installed with 3 phases. I made a panel with knobs and dummies to report current values. I also added a chart for persistence. The values from the meter are not updated unless I use the reset_meter switch. Then I get new values. In the log file this is confirmed. It is totally quiet until reset_meter switch is used. From the meter some values are send but not all. In addition, the values are confusing (phase 3 shows 0.4A current but a power of 34W).
At first lets get to a frequent update. I need your help on that.
Here more information:


From the clock and the log one can see that there is no automatic update. Although it should in my opinion, especially as the dish washer is working. That should create sufficient changes to the current.


The panel shows weired numbers. Or I do not understand the meanings. The knob settings for one knob is this:

I have the setting as follows. The aim was to get a frequent update of watts, kWh, and currents.


What I noticed is that there is no group setting. I that part of the issue?

System:
raspberry pi 3 running openhab 2.5.7-1
z-wave stick is: Aeotec AEOEZW090-C Aeon Labs USB Stick
z-wave binding: 2.5.7

Any idea what to test or which settings to change?

What’s weird about them?
if you have not dealt with three-phase before, it is pretty weird. The total power and currents is not simply the sum of the phases, there is complicated geometry going on in the calculations.
Apart from looking at phase currents for balancing reasons, it is most likely only the totals the meter calculates that are of interest to you.

Sorry, I have no help for your update issue.

1 Like

Wiered is that in phase 3 the current is 0.5A and the power is 64W. Shouldn’t it be IU so 0.5231=115W?

I can’t tell because I do not know the power factor of the load. The meter can measure that, and adjust its calculations.

I have an older model, so the parameters are different, but review how you are supposed to enter the reports 101-103. Is that a binary sum of all the report numbers? Also try to enable selective reporting

Bob

hello Bob, sorry I cannot read the text in your image. Could you increase the resolution please? Thank you for posting it.

I tried selective reporting enabled. It is also quiet in the log file.
Did you set up groups for reporting?

Trouble is I use this windows snip and sketch and I can only get get what’s on the screen. Let me try to get the part you may be interested in.

I do not understand the 4130571?

Also this was my very first device 3 years ago and it only reported every thirty minutes and I needed to call Aeotec. There were helpful. There is a windows tool that you can stick the z-stick into and it can put a command to the HEM. Anyway here is a sub snip. BTW I after the initial desire for more reporting, I have opted for very little. I persist the midnight KWH reading to compare with the electric bill.

4130571 is the sum of the according binary flags for reporting in decimal numbers. It is according to the manual. It is basically what you show in your settings, the selection of the reported values.
What was changed with the z-wave windows tool? I have it as well. That would not be the issue. It is interesting that you got it running straight away.
Do you know what you change with the windows z-wave tool? What is the setting for reporting interval and groups?

I wonder why there is a setting for reporting to group 1 but there is no setting input for group 1. :crazy_face:

It has been three years But I found an email I would advise opening a ticket with them.

Great! Thank you very much indeed. Very much appreciated. I will try the windows tool tomorrow and see what I can setup there using the parameter you show. (Btw. your mail address is visible :see_no_evil:)

It’s a spam bucket, but thanks for letting me know.

Also I was curious about the new device since I have an older model. You should go the aeotec support site. It has a calculator for the reports binary. I think you have the wrong number, plus if you want all the items, you should only have that number in report 1 AND 60 seconds is the minimum

I used z-wave PC controller 5 to read out the z-wave stick for node 51, which is the energy meter.
In the association groups I have this:

According to this link group 1 was set to controller. I do not know how to do it or if node 1.1 is maybe the controller. A setting menu like in the link in post jun’18 by “the elk”.

Does anyone have an idea what to change?

Okay, this problem is solved. With setting the association group in the meter by the zwave PC controller 5 to the controller it works (in the association group menu mark go to energy meter node mark under root device; group 1 and also mark the controller in the left menu and use create).
Now it looks like this:


under group 1 - Nodes (2) the 1 (beside the 1.1) is the important setting needed.

1 Like