Aeotec Multisensor 6 Reporting

  • Platform information:
    • Hardware: Physical Intel Xeon server with oodles of free resources
    • OS: Server 2019 Std
    • Java Runtime Environment: Zulu 11
    • openHAB version: 3.1.0.M2
  • Issue of the topic:

I have recently deployed openHAB with a mixture of Sonoff WiFi and Aeotec Z-Wave Plus equipment in my pool room with the intention of controlling pool room & water heating as well as the pool pump and dehumidifier.

Originally it was my intention to use a flashed Sonoff device to measure humidity and in turn power off/on the dehumidifier as and when needed but I found the Sonoff device not particularly accurate in its readings (I think the limited cable length and thus limited locations I could put the probe was a big factor here) so decided to use an Aeotec Multisensor 6 to measure humidity instead.

However, despite the Multisensor 6 being USB powered, I am struggling to get humidity reports from it on a regular basis. I have tried adjusting the wake interval and the group 1 report interval to get reports every 5 minutes but in reality, reporting is very sporadic yet when I tail the log, I see things like lux and temperature are being reported by the Multisensor every minute or so!

Ideally I want the humidity to be reported every X minutes (regardless of change or not) - is this even possible?



There are 4 different entries for multisensor 6, depending on the firmware version. Please post the xml file from the zwave folder of userdata created by OH. That contains firmware information reported by your device.

What you are asking would likely be an option under configuration parameters if the device supports the reporting you desire. Otherwise you may be able to create a rule that periodically polls the device for the value.

Thanks for replying Bruce! Here is the XML you requested:

OK your device version is 1.11 The documentation from the database is here.

It appears to be parameter 111 may accomplish what you wish if the device is in USB mode. The device mode is generally determined when first included into the network. If it is included when running on battery, it behaves as a battery operated device even id later USB powered.

There is an advanced parameter which can tell you which mode it is operating in.

The actual community maintained database entry is here.

Thanks, so param 111 has already been adjusted from 3600 to 60 as per however it is not reporting that often, some times it can be every 5-10 minutes, sometimes it might go 20-30 minutes without a report but only seemingly humidity as light and temperature it calls home about regularly.

EDIT: Is this the advanced param you are referring too?

It may be running in battery mode? I believe there is an advanced parameter that could tell you.

Is this what you are referring too:

Yes. That says the sensor is running in battery mode.

If battery power, the minimum interval time is 60 minutes by default, for example, if the value is set to be more than 5 and less than 3600, the interval time is 60 minute

If you exclude from the network, delete the Thing & rediscover it may have a new ID in OH meaning you would need to adjust your Item links. If excluding I would recommend factory resetting the device before re-including. Some devices behave better after a factory reset when including. Be sure the sensor is on USB power before including…

Weird, its been plugged in since the get go, I’ll try and remove it from my system now and re-add although for some reason, removing z-wave stuff from openHAB has been proving to be difficult so far, devices remain present even when I select “Remove device from controller”

The Thing stays in OH and must be deleted manually.

So I think there may have been a misinterpretation of the output as the status is the same after forcibly removing, factory resetting the ‘thing’ and re-pairing.

Apparently if ‘Power State’ shows as 0 then it is USB powered vs battery?

In any event, I’m not back to trouble shooting why my Aeotec TRV has dropped from the network following a network heal (due the removal and reintroduction of the Multisensor) and why when I get a ‘Error: Comm’ things don’t self heal :frowning: