Aeotec Multisensor 6 temperature units doesn't stay set

Openhabian, openHAB 2.4.0~20181004001205-1 (Build #1380)

I can set the temperature units to Fahrenheit, power the device (it’s on a wall wart) and the initial temperature output is in the desired units.

But, subsequent reports are in Celsius.

The thing in Habmin shows all temperature related units are set to Fahrenheit.


Have you modified your items to use UoM, or set your locale in PaperUI?

Umm…have to go look what UoM is. :confused:

No locale set in PaperUI…other language setting, I don’t see anything about locale in PaperUI > Preferences. :thinking:

Units of Measure.

You would define the item to look something like this.

Number:Temperature Kitchen_Temperature  "Kitchen Temperature [%.1f °F]"  { channel="zwave:device:zstick:node38:sensor_temperature" }
1 Like

Configuration> System> Regional Settings (show more)…

Duh… :blush:

But, this sitemap entry is just displaying the value that it gets from the MS6:

    Frame label="Status" {
        Text item=ms6_temperature label="Basement Temperature" icon="temperature"

And if I power cycle the ms6, the value is 67, then after update it reads 19.

Arrrgh, wait, I just looked at the openhab app on my pone and it is reporting F. After the ms6 being powered all day.


I swear, it showed up Celcius twice! :face_with_symbols_over_mouth:

It probably did! One of my devices (I can’t remember if it was the ZW100 or the FGMS001) was reporting temperature in F and C randomly until I defined the item using the UoM method).

Not really. The binding will pass through the temperature reported by the MS6, along with the units it is reported in. The framework will then convert this into whatever units you specify and this is what is displayed in the sitemap.

I guess if UoM isn’t configured, then you probably get whatever the device sends, but I wouldn’t be 100% sure of that as it’s down to the way the framework works.

That looks like quite a recent version or the zwave binding, I had to roll back from 2.4 M4 as my device did not respect the UOM that was set (strangely it did report the correct unit when I re-initialised but then fell back to the default. Works fine in M3). Chris - I have the zwave trace logs, do you want me to open a bug in github?

I’m not sure how #1380 relates to 2.4 M3/4, but, I did not note this behavior until I switched to #1380.

I have now set the UoM in PaperUI. (Imperial(US))

In the PaperUI this (in the .items file) gets 2 decimal points, but no “F” in PaperUI > Control:

Number ms6_temperature "MS6 Temperature [%.2f %unit%]" {channel="zwave:device:16500637f6a:node17:sensor_temperature"}

This gets 1 decimal place and no “F”:

Number ms6_temperature "MS6 Temperature [%.1f %unit%]" {channel="zwave:device:16500637f6a:node17:sensor_temperature"}

I don’t think I grok what I read here :confused: :

What does that mean exactly?

I’d prefer to understand the issue first, and we can create an issue once we know if there’s actually a bug. Can you post the logs please?


Number:Temperature ms6_temperature "MS6 Temperature [%.2f %unit%]" {channel="zwave:device:16500637f6a:node17:sensor_temperature"}
1 Like

Ok, I get it now, the Number:Temperature tells it the number is of the type temperature and to use the system UoM.

But, now PaperUI > Control and the android app show 67.8 (degree symbol here…cuz I don’t know how to make one in this forum editor :roll_eyes: ) C.

And occasionally 19.2 'C. And the UoM is set to Imperial… :unamused:

Some days… :smirk:

Two things come to mind, but not sure if they will help. Set your Country/Region, if you didn’t. And maybe the system needs a restart for the settings to really take affect.

Well…I had set the region, language, Measurement System, and time zone in PaperUI > Configuration > System

But, after reboot those settings are blank again.

And PaperUI and Android app is showing 19 'C.

Edit: attempting to set these again, notice the save button does nothing…So, it looks like it wasn’t/isn’t set.

Did you save the settings after changing them? It’s easy to miss, but look at the bottom right of this image…

The Save button highlights when I hover over it, but nothing happens when I click it. (And nothing shows in the log.)

Actually, after I put in my longitude and latitude it allowed me to save.

But, still showing Celcius…rebooting now to se if that changes things.

Also, why, after I saved the setting (including the lat/lon) did it find new astro sun and moon in PaperUI?

I have simple mode turned off, I thought it didn’t auto discover.

I see the same behavior… probably need an ESH issue logged for it. I did a quick search and didn’t see one. You found the bug, so you get first dibs!

Ok, so after reboot PaperUI > Control still shows the correct temperature in C.

And the Android app shows the correct temperature in F.