Aeotec Smart Switch 7

Actually this was imported from the XML Bruce :slight_smile:

1 Like

unfortunately the switch does not work for me with openhab
in items config file the important definition looks like this:

Switch LivingRoom_ZW175_Dimmer “Dimmer” (LivingRoom) [""] {channel = “zwave:device:32a465ba:node5:switch_dimmer”, autoupdate=“false”}

but the only thing i can switch off and on is the led on the switch but not the load ?!

to me it looks like we miss the binary switch

btw: with dimming you can dim the led on the switch, the switch itself has no dimmer built in, its a switch not a dimmer

Actually you are wrong. Here are some of the command classes it officially supports.

From the manufacturer providing to the zwave alliance at

I would agree- it looks like this needs both switch and dimmer channels. Normally I would have expected these to be implemented inferential endpoints to split the functionality, but it doesn’t seem like that has been done here unfortunately.

My last change to the database was to add the switch_binary channel again and set the switch_dimmer to deprecated.
Is this okay or do we need more edits?

It seems that both channels are needed as they do different things if I understand the above correctly. It looks like the switch_binary channel does the actual switching of the load, and the switch_dimmer channel just controls the LEDs on the switch?

If so, then both channels would be needed and we should not deprecate the switch_dimmer. It might pay to name the switch_dimmer something like “LED control” or something similar to try and make this clearer?

Done and removed the deprecated flag.

1 Like


I will hopefully be home on Wednesday and I’ll try and do a database update then if I’m not too :tired_face: after a 14 hour flight…

Have a save flight.


Should the binary switch be set as basic? That might cause issues too.

Probably, yes.

The initial, unaltered contribution of the xml file show this as correct:

            "id": "25",
            "name": "SWITCH_BINARY",
            "version": "1",
            "nif": false,
            "basic": true,
            "secure": false,
            "nonsecure": true,
            "config": "",
            "channels": [
                    "type": "switch_binary",
                    "label": "Switch",
                    "config": []
1 Like

please check the product page from the manufacturer and show us the described dimming function

also from the current enabled command classes the only thing i am able to dimm is the LED in the switch but nothing else

from screenshot @Chris_Thomsen posted
Dimmer swich on|off the LED
Color Control no function visible
Brightness dimm the LED
Saturation no function visible
Color Temperature no function visible

Load not switchable

As we know now from above posts: the switch_dimmer channel controls the device LED and the switch_binary channel controls the load, so everything should be good.

1 Like

I can see that the binding on github is updated. Many thanks for this guys. Will I get this version if I reinstall my openhab Z-Wave binding? Then I’ll try again this weekend to see if I get it working.

If you install the latest snapshot binding then the answer is yes.

interesting, i use the latest docker snapshot openhab/openhab:2.5.0-snapshot (deleted the old image files so everything new downloaded) but still don’t see the new binary switch channel

If you haven’t done so, you will need to delete the thing, and rediscover (no need to exclude the device). This allows the binding to pick up the updated definition, otherwise openHAB uses the old definitions and you will see no change.

1 Like

I got it working now. I can toggle the power state ON and OFF!

Thanks for the support!


I’ve got now two of the switches and I wondering about parameter 9. Parameter 9 is to set the alarms on what the switch will react to. But… I can not choose multiple alarms because it is a single combobox in habmin. It would be better, if parameter 9 is splitted into multiple paramters with different bitmasks, right?