Aeotec Z-Stick Gen5 w/Ubuntu guest on Win8.1 Virtualbox Host

Hey there,

I’ve got a Aeotec Z-Stick Gen5 which I’ve successfully gotten running with OpenHAB and my device (only one so far) on a Windows 8.1 based server.

I’m in the process of migrating OpenHAB to a Ubuntu (14.04.3) server which is in fact a VirtualBox guest on the same machine. In Virtualbox I filtered the USB to the Linux server (there’s only one USB device, so it was easy to pick) and Ubuntu does seem to see the device via lsusb (it’s the Sigma Designs one):

vagrant@ha:~$ lsusb
Bus 001 Device 002: ID 0658:0200 Sigma Designs, Inc.
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

What it doesn’t seem to ever do is mount it at a /dev/ mount point. I’ve checked the dmesg log, kern.log etc… They all report when the stick is removed or replaced - but never a /dev mount point.

If I try and use the suggested /dev/ttyS0 I see in my zwave.log:

2015-10-17 22:29:15.524 [INFO ] [b.z.i.protocol.ZWaveController:320 ]- Connecting to serial port /dev/ttyS0
2015-10-17 22:29:15.628 [ERROR] [b.z.i.protocol.ZWaveController:342 ]- Serial Error: Port /dev/ttyS0 does not exist

In Windows, the stick is COM3, so I’ve also tried /dev/ttyS2 (same result). I’ve compared the /dev/ listing before and after plugging in the device - you can see it happen in the kern.log, but no new device in /dev

Is anyone using a similar configuration? Any trick I’ve missed or could try?

I am running Linux Mint and my Z-Stick is mounted under /dev/ttyACM0

Should be the same for Ubuntu I think.

Are you running Mint on a VM or on bare metal? I’m sure it would work fine for me on Ubuntu if it wasn’t virtual. That’s my complication.

Hi Andre!

Did you try a “ls -ahl /dev/ttyACM*” (without the quotation marks). Your system will have created the device node for you after the kernel recognizes it. Actually the stick will not be mounted - ever. The device node is created dynamically and that is all you need. Basically I think your problem is a permission problem.

I am running a test environment in VMWare (not virtual box) and bare metal as my “production” home automation. Both have the same mount points. Have you tried mounting any other USB device into the Virtual Box machine, Previously I had lot of issues with virtual box that why I moved to VMWare.

This is never created.

vagrant@ha:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0658:0200 Sigma Designs, Inc.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
vagrant@ha:~$ ls -ahl /dev/ttyACM*
ls: cannot access /dev/ttyACM*: No such file or directory

No I haven’t… I’ll see if I can give that a try. One thing that’s somewhat interesting is Virtualbox when I try to map the USB to the guest labels it as an ‘Unidentified device’. Not sure if that makes a difference or not - the Vendor/Product ID is correct.

If I ‘virtually’ remove and plugin the device (from Virtualbox’s Device menu while the machine is running), I see this in kern.log:

Oct 19 20:23:38 ha kernel: [  884.226404] usb 2-1: USB disconnect, device number 3
Oct 19 20:24:41 ha kernel: [  946.877072] usb 2-1: new full-speed USB device number 4 using ohci-pci
Oct 19 20:24:41 ha kernel: [  947.322254] usb 2-1: New USB device found, idVendor=0658, idProduct=0200
Oct 19 20:24:41 ha kernel: [  947.322264] usb 2-1: New USB device strings: Mfr=0, Product=0, SerialNumber=0

Can you try this and send results:

dmesg | grep ACM

Nothing… No results.

I’ve also just tried:

  • upgrading Virtualbox to v5.0.6 - no help
  • installing VMWare Player and migrating the box there - no good either

Well, I’ve also now tried just creating a brand new VM, same Ubuntu release (14.04.3) and it works (VMWare)! So there’s something different about my original VM?

Great! Sometimes difficult to track virtual hardware mappings… not sure what the cause could be tough.

Fwiw I recreated a new vm on virtualbox using Vagrant and the official Ubuntu 14.04 release. It exhibited the same problem, so I skipped Vagrant (don’t really need it for this anyway, it’s just a habit) and created a new VM still in VirtualBox, using the Ubuntu iso. This worked correctly (like VMware did).

So, I now have a working VM. Maybe that Vagrant image doesn’t have usb compiled into the kernel or something, hard to say.

Thanks for the suggestions.