Aeotec ZW098 LED Bulb FWv1.5 Color Temperature


Just added the ZW098 LED Bulb and I can not get the Color Temperature of the bright white setting to work. The RGB saturation and RGB color mixer works OK.

With these settings, should I see any difference in the white light when sliding the Color Temperature?

Running the refactored Z-Wave binding:

Another thing I noticed was that including the bulb in a group, sending ON to the group turned the bulb on at 100% intensity. All other dimmers just restored their previous setting (even Ikea Tradfri :slight_smile: ).

Any thoughts @chris?

Please can you describe what “I can’t get it to work” means? What happens? Nothing? Does the warm (or cold) level change?

The binding provides the color balance feature by adjusting the value between the warm and cold channels. Maybe this bulb doesn’t allow both cold and warm channels to be operated at he same time.

If I get a chance I’ll try and test it here, but it will likely be next week before I get time so if you can provide a bit more information it would be useful.

You need to change the setting “Restore last value” if this is how you want it to work.

Absolutely nothing happens. Will try with debug log on.

No such Configuration Parameter: (but list starts at #32. Strange?)

Ok - it may simply be that it’s not allowed by the device. The device doesn’t provide this function, so I’ve tried to support it though the binding - this works with the Zipato bulb as I’ve tested it but I’ve not tried it with the Aeon (although I do have one here, but I’ve not tried it).

Let’s see what the log shows…

It’s not a device parameter - it’s a configuration option in the channel.

Hmm, for Nexa Wallplug dimmer it is.
Found it, but it is not working. Tried to toggle it back and forth. Still the same.

Sorry - I’m confused what you mean. It works on the Nexa, but not the bulb? Or something else?

Again, let’s grab a log to see what’s happening.

Right, here is what happens when I slide the color temperature.
(I am pretty sure the bulb supports it. Says whites in 2580K - 7050K on the box.
Stuck at 7050K it seems, blueish light.)

2017-04-29 13:05:41.293 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 37: Command received zwave:device:15b9cb3d46b:node37:color_temperature --> 38
2017-04-29 13:05:41.294 [DEBUG] [ding.zwave.handler.ZWaveThingHandler] - NODE 37: No messages returned from converter

Yes, for all other dimmers, but the Nexa ones have a Configuration Parameter for it as well.
All have the channel setting as well. Just the bulb that doesn’t restore last level.

Pulling the log now: massive amount of DEBUG entries, will take a while.
Noticed it worked intermittently when turning group OFF/ON, but never 3 times in a row.

Also note, that my bulb has firmware version 1.5. Could something have gotten broken since 1.4?

Did it work ok on a 1.4 version bulb?

If it works even once, then the setting is probably ok. If it only doesn’t restore the last value when using within a group, then it’s possible it’s something else causing the issue - I would take a look at exactly what command is being received by the binding.

Wouldn’t know. This is my first such bulb, and the primary reason I bought it (apart from Z-waveification) was to get a warmer whiter light. The RGB light is nice for parties :slight_smile:

I will do that, but RL (RealLife) is calling. Thanks for your time so far. I’ll keep you posted.

Just to wrap this up. @chris

This is the answer I got from Aeotec regarding the white level settings of the high-intensity non-RGB part of this bulb.

There are only 2 white level settings, Cold White and Warm White, which can also be changed within the color command class settings for Color Set command. The option is limited if you are not planning to use RGB to create a warmer white color in this case. The RGB color mixtures are possibly the only way to achieve a much warmer LED light.

These 2 white level settings are not controllable by OH2 at the moment, but what they call warm-white is far from it. Nothing warm about it, and going for RGB will yield a lot less intensity. It is not possible to mix RGB in with the white.

The way OH2 works is to control the two whites - scaling between the two of them. So, if you want cold white, then cold is 100% and warm is 0%. Something in between might be 50% each, and warm would set the warm LED to 100% and the cold to 0%.

This works with the Zipato bulb but I’ve not tried it on the Aeon but I think they may allow only 1 white LED on at once. I do have an Aeon bulb so will try and find some time to test it over the next week.