Aeotec Zwave Controller and Openhab3

Dear all,

I have been using Openhab for more than 2 years and, thanks to the assistance of some of you, I managed to configure and make my home automation system correclty work .

I tried to upgrade from Openhab2.5 to 3.xxx

It has been a little bit difficult to understand the new approach but the developpers did really a great job and, once again, thanks to the forum, I managed to make things work … except for … zwave (which was perfecly working with 2.xx version).

I know there have been plenty of discussion about this topic, I read them, tried the suggested solutions but unfortunately, it does not work for me.

Tu summarize, I am unable to add all my Zwave devices to openhab and I do not think it will ever work.

I fully understand that this new version is probably uncompatible with my Aeotec I am trying to find another solution which would be more compatible with openhab3

What would you suggest me ? I only need motion sensors.

Thanks for your assistance.

King regards.

There are many more users here with aeotec sticks working with OH3 (myself among them) than there are people who have had issues. The problem is not the aeotec stick + OH3, the problem is something about your system configuration. In order for us to be able to help you trouble shoot that, we’re going to need many more details.

  • What device are you running OH on?
  • How did you upgrade/install OH3?
  • How did you configure your stick in OH3, files or UI?
  • What do you mean by “unable to add all my Zwave devices to openhab”?
    • Is the stick offline?
    • Does it fail to add any devices to the inbox when scanning?
    • Are there any errors in the logs when you try to add devices?
  • Were any of your devices previously added securely? (Probably not as you mention mostly having motion sensors, but other have had security key issues when moving setups.)
1 Like

I’m using the Aeotec Z-Stick Gen5 with OH 3.2 on Windows and it works fine. This stick is quite popular among OH users, as far as I can tell. It appears the root issue with the solution you linked to was related to the port settings of the computer, and unrelated to the binding. In any case, I just wanted to chime in that this stick is compatible with OH3, but unfortunately I’m too much of a newbie to help you diagnose what is the exact cause of your trouble. Good luck.

Thanks for your answers, I really appreciate (to be fully honest, I am or was about to give up).

OpenHab is installed on a Raspberry Pi4; fresh install of the v3 (the 2.XX is still runing on another Pi).
I tried to configure the usb Aeoteck stick through UI (add new thing :Zwave / Zwave serial controller)
Serial port = /dev/ttyAMA0
And that’s it.

  • I changed the line in the change /etc/tmpfiles.d/legacy.conf from
    d /run/lock 0755 root root -
    to
    d /run/lock 0775 root dialout -
    Bridge was still offline.
  • Disabled serial console to give room for Hats, moved bluetooth to mini UART
    Bridge was still offline.
  • Tried the workaround solution consisting in installing ser2net service but did not find the ser2net.conf
    Bridge was still offline.

I am really sorry to bother you with my problems; I am far from being talented. I am just trying to find a solution but did not find one, even after having read dozens of topics on the same issue.

OK, based on this, I think you were on the right track with the USB hub idea. This is a very well known issue between the first generation Aeotec Sticks and RPi4’s. Supposedly, the new generation of Aeotec sticks don’t do this anymore, but if you’ve been using your for a couple of years in OH2 then you almost certainly have the old version that causes this problem. (And you haven’t seen the problem on your OH2 because earlier RPi’s didn’t have this issue either.)

You say you tried a USB hub, already, but there’s a catch: the hub specifically has to be only a USB 2.0 hub, I believe. A hub rated for USB 3.0 will still pass along the error that it caused between the stick and the RPi’s USB controller.

Besides the USB2.0 hub are you sure the zstick is on

/dev/ttyACM0 is also common. could check dmesg.

Bob

1 Like

Not so old in fact, it is a Gen 5 purchased in 2019; I tried with another Aeotec Gen5 (purchased later in 2021) but the problem is still there. I read in other forums that the compatibility between Raspberry Pi4 and Aeotec Z-Stick Gen 5 was common and they also suggested to try with an externaly powered USB 2 hub. Unfortunately I do not have one but will order it and give it a try.
To answer apella12 question, /dev/ttyACM0 was the only proposed port in UI; I used dmesg and got the following lines for “usb”.

changed the line in the change /etc/tmpfiles.d/legacy.conf from
d /run/lock 0755 root root -
to

[498219.686575] usb 1-1.3: New USB device found, idVendor=1a40, idProduct=0101, bcdDevice= 1.11
[498219.686597] usb 1-1.3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[498219.686616] usb 1-1.3: Product: USB 2.0 Hub
[498219.697107] hub 1-1.3:1.0: USB hub found
[498219.697881] hub 1-1.3:1.0: 4 ports detected
[498222.365946] usb 1-1.3.2: new full-speed USB device number 4 using xhci_hcd
[498222.602990] usb 1-1.3.2: New USB device found, idVendor=0658, idProduct=0200, bcdDevice= 0.00
[498222.603013] usb 1-1.3.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[498222.670154] cdc_acm 1-1.3.2:1.0: ttyACM0: USB ACM device
[498222.673539] usbcore: registered new interface driver cdc_acm
[498222.673548] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
[498246.313605] usb 1-1.3: USB disconnect, device number 3
[498246.313629] usb 1-1.3.2: USB disconnect, device number 4
[498248.145949] usb 1-1.4: new high-speed USB device number 5 using xhci_hcd
[498248.276627] usb 1-1.4: New USB device found, idVendor=1a40, idProduct=0101, bcdDevice= 1.11
[498248.276650] usb 1-1.4: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[498248.276668] usb 1-1.4: Product: USB 2.0 Hub
[498248.278352] hub 1-1.4:1.0: USB hub found
[498248.278495] hub 1-1.4:1.0: 4 ports detected
[498248.695960] usb 1-1.4.2: new full-speed USB device number 6 using xhci_hcd
[498248.942964] usb 1-1.4.2: New USB device found, idVendor=0658, idProduct=0200, bcdDevice= 0.00
[498248.942987] usb 1-1.4.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[498248.950395] cdc_acm 1-1.4.2:1.0: ttyACM0: USB ACM device
[498257.009173] usb 1-1.4: USB disconnect, device number 5
[498257.009201] usb 1-1.4.2: USB disconnect, device number 6
[498258.255957] usb 1-1.1: new high-speed USB device number 7 using xhci_hcd
[498258.386550] usb 1-1.1: New USB device found, idVendor=1a40, idProduct=0101, bcdDevice= 1.11
[498258.386572] usb 1-1.1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[498258.386591] usb 1-1.1: Product: USB 2.0 Hub
[498258.388235] hub 1-1.1:1.0: USB hub found
[498258.388384] hub 1-1.1:1.0: 4 ports detected
[498258.805967] usb 1-1.1.2: new full-speed USB device number 8 using xhci_hcd
[498259.043013] usb 1-1.1.2: New USB device found, idVendor=0658, idProduct=0200, bcdDevice= 0.00
[498259.043036] usb 1-1.1.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[498259.050272] cdc_acm 1-1.1.2:1.0: ttyACM0: USB ACM device
[498269.679848] usb 1-1.1: USB disconnect, device number 7
[498269.679876] usb 1-1.1.2: USB disconnect, device number 8
[498271.455936] usb 1-1.2: new high-speed USB device number 9 using xhci_hcd
[498271.586638] usb 1-1.2: New USB device found, idVendor=1a40, idProduct=0101, bcdDevice= 1.11
[498271.586661] usb 1-1.2: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[498271.586680] usb 1-1.2: Product: USB 2.0 Hub
[498271.591156] hub 1-1.2:1.0: USB hub found
[498271.591306] hub 1-1.2:1.0: 4 ports detected
[498272.005953] usb 1-1.2.2: new full-speed USB device number 10 using xhci_hcd
[498272.243003] usb 1-1.2.2: New USB device found, idVendor=0658, idProduct=0200, bcdDevice= 0.00
[498272.243026] usb 1-1.2.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[498272.247912] cdc_acm 1-1.2.2:1.0: ttyACM0: USB ACM device
[498279.807372] usb 1-1.2: USB disconnect, device number 9
[498279.807400] usb 1-1.2.2: USB disconnect, device number 10

Ok, good news, I finally managed to get in online.
After having tried the ser2net workaround (in fact, the .conf file is the .yaml file if I understood well) which did not really work, I rebooted the raspberry, ticked the 2 options (disable serial console to give room for Hats and move bluetooth to mini UART), rebooted once again, created a new thing with zwave binding and /dev/ttyACM0 as serial port and, miracle, it showed online.

Thanks once again for your patience and your assistance !!!

Have a nice week-end !