Aeotech MultiSensor 6 problem

The Aeotech Z-Wave Stick finds the MultiSensor…
Z-Wave Node 2: ZW100 MultiSensor 6
Unknown Device

I add it as a Thing and it gets saved successfully. Once I go and try to edit the Thing, the checkmark icon is grayed out so it won’t save the configuration.

Would really appreciate any suggestions or help! Thanks

Are you adding it over wifi or usb? If over wifi it is a common trait of zwave devices to take a few wakeup cycles before being fully recognised (which your isn’t). Either give it some time, or wake it up several times for it to do its thing and it should be OK.

Thanks @pahansen… I’m not sure what you mean about adding it over wifi. It uses battery or USB for power. I have tried it both ways with the same result. So when you say wake it up, you just mean to press the action button every few minutes and then check to see if I can edit/save the Thing configuration? I really appreciate your time and help. I’m off to bed now but will get back on this tomorrow after work.

Sorry, by wifi I meant on battery.

Isn’t there a way to turn the multisensor on for 10min if on battery power? Like holding the button down for three seconds or something? It’s in the user manual.

No worries… yes, I read that and that’s when I decided to go with direct USB power after removing the battery. Same result though. The Sensor is discovered and shows up in the Inbox. I add it successfully but can’t save any edits made since the checkmark button is grayed out.

I’ll keep trying today after work but any other suggestions would be much appreciated. Thanks!

maybe try it through the habmin ui?

You have to reset the device to change the initial power setting. Meaning, if you first powered it with batteries then it is in a Batteries configuration until you RESET the device. If it is your goal to power through USB, go ahead and reset, simply pulling the batteries does not change the configuration. You do need to wake battery devices to complete the initialization. These sensors are great, you just need to understand how they work/communicate.

1 Like

Thanks @Toneus… I’ll reset it and try again when I return home from work today. I’m glad to hear these are great sensors! Appreciate your time and I will report back.

After a reset I’m still having issue. The sensor is discovered, shows up in the Inbox and I add it as a Thing. I go to edit the Thing config and I can’t save anything. What should I try next? Thanks!

Resetting the device is simply to change from a Battery configuration to the USB configuration.

You have to use HABmin to save parameters. PaperUI will be blocked because of the bad parameter. Do you have HABmin on your start page? Go to your http://openhabhost:8080/habmin/index.html#/home Replace openhabhost with your ip or openHAB server name.

Then go down to Configuration / Things on the left. And then Configuration Properties of that Thing.

You can edit Channels in PaperUI.

@Toneus… I do not have HABmin on my start page. I’d like to install it.

I installed HABmin. Went to the Sensor Configuration Parameters page. I change the “Report the current power mode” to 1. I clicked save and it now shows “Pending…” for the past 10 minutes. What next? Thanks you for the help.

That parameter is not editable. It is reporting only, incorrectly also. So it will not return. Either the parameter was defined incorrectly in the Z-Wave DB, or the device is reporting incorrectly. You’re going to just have to leave it alone until it’s fixed in the binding.