After update to 3.1, some homematic items are not updated anymore


after updating to 3.1, all of my Homematic Things/Items did not work anymore until I upgraded to the SNAPSHOT version provided by @MHerbst.

openhab> list -s | grep homematic
322 │ Active │  80 │    │ org.openhab.binding.homematic

Now some things/items work again, but for example my Energy Sensor is stuck on the last value that was received before the update.

After enabling the DEBUG log, I can see that the binding receives the value correctly

2021-09-20 18:00:48.129 [DEBUG] [ommunicator.AbstractHomematicGateway] - Received new (Double) value ‘421.0’ for ‘SEQ137xxxxx:1#IEC_POWER’ from gateway with id ‘ccu’

But this value never reaches my Item, and already the Thing looks destroyed in the standard web view:

Any idea on how to troubleshoot this further?

Best regards

This looks like a problem with the item definition. How are your items defined? Text file or in Main UI? You can try to remove the thing, run a new scan and create it new.

Dear @MHerbst,

I doubt that my Item or Thing definition is the cause of the behavior, as it worked perfectly with the previous version.

I’m using file-based definitions for everything, so here are the relevant parts of my configuration for your reference:


	Thing HM-ES-TX-WM 	SEQ13xxxxx		"Energiesensor Strom" @ "Hauswirtschaft"


Number:Power 	Stromzaehler_Power				"Stromzaehler Power [%.2f W]"				(gPower)			{ channel="homematic:HM-ES-TX-WM:ccu:SEQ13xxxxx:1#IEC_POWER" }
Number:Energy	Stromzaehler_Energy_Counter 	"Stromzaehler Energy Counter [%.2f kWh]"		(gEnergyUsage)		{ channel="homematic:HM-ES-TX-WM:ccu:SEQ13xxxxx:1#IEC_ENERGY_COUNTER" }

Does this help or do you have any other idea how to advance the debugging?

Best regards,

I would test what happens if you define the thing and an item via Main UI. As far as I remember, there are some problems with text files, but I can remember exactly what the problem was.

Then you could set the log mode for the Homematic binding to TRACE, restart OH and post the openhab.log from the beginning of the restart. Maybe it can help to find out what’s going wrong.

Hello @MHerbst - thank’s for the hint, that pointed me into the correct direction. I found out, that this Thing now needs to be configured as a HM-ES-TX-WM2 and the works perfectly again. Previously, it worked without the “2”.
Best regards,

1 Like