After upgrade on OH3 i cannot add to google Home app / link to google assistant

Hi Everybody!
I had for 2 Years no problem with google home / openhab
yesterday (i decided to take time and upgraded to OH3.1, i tried milestone and latest snapshot aswell)

Install worked and evrything is UP and running, Openhabclound is also “ONLINE”

because something didn’t worked, i UNLINKED openhab in googlehome app, and since thenn, whenn i want to LINK it again to openhab, i get AUTH prompt, and if i click on “AUTH” it disapears and i get a black warning “couldnt linked, check your connection”

the strange thing: in myopenhab i see the link is authorized and in google, whenni check it with the computer on https://myaccount.google.com/accountlinking i also see the openhab as “linked” app…

but i wont work on the googlehome app, it’s not activated there and i see no devices

  • i tried cache googlehome deleted,
  • tried a different mobilephone with different google user, same behavior
  • i also tried a new “home” with different user, same behavior

does anybody can help me or point me to the right direction?
Thank you in advance!

One thing that trips a lot of users up is you much have at least one Item with proper ga metadata defined. If you don’t, Home will reject the connection.

Here is from my text file 2 items, i think it’s correct defined:
Switch HEOS_WZ_START_Trigger “Heos” {ga=“Switch”}

Dimmer Heos_Gruppen_Volume “Lautstärke” {ga=“Light”, channel=“heos:group:bbcc9637-9fae-1a88-0080-0005cd3ca7ec:3490457483:Volume”}

or do you see any problems here?

what i don’t understand is, whenn i make a rest api request to this item:
http://192.168.2.104:8080/rest/items/HEOS_WZ_START_Trigger

i receive:
{
“link”: “http://192.168.2.104:8080/rest/items/HEOS_WZ_START_Trigger”,
“state”: “ON”,
“editable”: true,
“type”: “Switch”,
“name”: “HEOS_WZ_START_Trigger”,
“label”: “Heos”,
“tags”: [],
“groupNames”: []
}

i can’t see there the googleassistant tag, is that normal?

Any help would be very nice! …

The google assistant data is not stored as a tag, it is stored in the metadata.

Try: http://192.168.2.104:8080/rest/items/HEOS_WZ_START_Trigger?metadata=ga to see it.

Oh okay…but what could it be that i can not link with google home anymore

i found the solution!
after enabling:
API Security
Implicit user role for unauthenticated requests

it worked! i still cannot believe it…hope it helps others!