Alexa and Hue Emulation - No devices discovered

Tags: #<Tag:0x00007fc1fbed8a40> #<Tag:0x00007fc1fbed8978> #<Tag:0x00007fc1fbed88b0>

Hi @Celaeno1

thanks for your reply. I’ll investigate further then. The channel is missing because I have multiple OpenHAB instances running in my house synced through MQTT and eventbus, so not every item has a channel on the main instance. :slight_smile:

Do you know who maintains the Hue Emulation binding or whether it’s dead, because I added an issue on the openhab-addons issue tracker on Github but seems those for Hue Emulation are not looked at, since there’s other issues as well without comments.

digitaldan

Thanks @Celaeno1.

So let’s ping @digitaldan :slight_smile:

I’ve been trying to ping Dan for about a month with other HUE Emulation issues…but it looks as if he may have gone silent.

I’m hopeful he will come up for air soon…he has always been of great assistance.

I’m sure he probably has real world issues requiring his attention.

https://community.openhab.org/t/hue-emulation-alexa-not-responding-after-2-2-upgrade/
1 Like

Dan is quite busy with updates and fixes for the IOS and Android apps

@antares2001 @hmerk

The reason why “TargetTemperature” is not running anymore, could be:

“TargetTemperature” is missing in Line94.

@digitaldan Do you know about this? Was it ever there?

see also here in Line83:

https://programtalk.com/vs/openhab2-addons/addons/io/org.openhab.io.hueemulation/src/main/java/org/openhab/io/hueemulation/internal/HueEmulationServlet.java/

@Kai Maybe you know the reason why “TargetTemperature” is gone?

1 Like

I have the Echo 2gen working now. You have to change discovery port to 80 and forward all requests on port 80 to 8080 (or whatever you openHAB port is). On linux this can easily be done using iptables.

Afterwards, the Echo detects the devices and can switch them on and off. You get an error message when turning things on, but it works. You can get rid of the error message with a change to the hue emulation code.

See the related issue for details:

Well, I have a similar problem but not quite the same.
I have two echo dots, I also ordered one of them during the cyber Monday week.

I am using openhab 2.2 (openhabian) and set up hue emulation some time ago. But at this time I already had both echos.

Hue emulation was working perfectly since then. It still works like a charm (without errors) but I added a new switch item yesterday which Alexa just doesn’t want to discover… May this be related to your problem?

Item definition:

Switch Wohnzimmer_PC "Fernseher" <screen> (Wohnzimmer, Steckdosen) ["Switchable"]

I tried to reinstall the hue emulation binding and tried discover while being in pairing mode again, but it didn’t work.
I don’t want to delete all devices because I fear that will also be not found anymore.

Edit: FIXED IT :slight_smile:
I had set up the LAN port of the Raspberry Pi (connected to network via wifi) as a wake on lan source for my wifi connected PC.
I had to specify the wifi-interface ip address in the hue emulation configuration. Now it’s working as expected again.

Same here for Echo Spot. it working now after forwarding port 80 to 8080 by iptable and config the discovery port to 80 under openhab hue emulation services.

i checked out the related issues.

According to http://www.burgestrand.se/hue-api/api/lights/, this is not allowed in the Hue API. If I change the code in HueEmulationServlet.java (line 481) to return 254 instead, alexa no longer complains when items are switched on.

May i know where and how to change the code to get rid of the error message?

Do you have issues with TargetTemperature tagged devices?
I have no issues with Lighting or Switchable items, but TargetTemperature items are not discovered by Alexa :frowning:

Item definition:

Number Test_Temperatur "Temperatur Küche [%.1f °C]" <temperature> (Temperatur) [ "TargetTemperature" ] {channel="mysensors:temperature:e50852a4:temp"}

This could be the reason:

@digitaldan Is this true?

In former times it was:

private static final String[] SUPPORTED_TAGS = new String[] { "Switchable", "Lighting", "TargetTemperature" };

Hi All :slight_smile:

Went and bought the Amazon Echo (2nd Gen AU region) yesterday. Initial setup of it was flawless, however I am pulling my hair out now trying to integrate it with the openHAB. Due to lack of Alexa skill in AU region, I’ve gone down the road of HueEmulation…

  • Openhab version 2.2 runs on port 8080
  • Hue Emulation 2.2.0 (discovery web port set to 80 and port forward is setup with iptables 80 ==> 8080
    one switch was tagged as “Switchable” and I can see it in /api/discovery.xml
{"lights":{"1":{"state":{"on":false,"bri":-1,"hue":0,"sat":0,"xy":[0.0,0.0],"ct":500,"alert":"none","effect":"none","colormode":"ct","reachable":true},"type":"Dimmable Light","name":"Kitchen Switch","modelid":"LWB004","uniqueid":"1","manufacturername":"openHAB","swversion":"66009461","pointsymbol":{"1":"none","2":"none","3":"none","4":"none","5":"none","6":"none","7":"none","8":"none"}}}}
  • Amazon Echo is setup on the same subnet as openhab (10.100.100.0/24)
  • UPnP is enabled on the router (torrent works :slight_smile: )
  • debug log shows nothing… no attempts from the Echo to pull /api/description.xml or /api/discovery.xml

Any ideas would be greatly appreciated :slight_smile:

Thanks
Alex.

Here is a good thread. There is a section that I posted with the steps. If I had to guess your item is not defined properly, or the Device Pairing is not enabled. The HE Binding simply works.

I’ll keep an eye on this thread to try and help further.

Cheers!

Tony

@Toneus Hi Tony, which thread are you referring to?

Oh gawd!.. starting to think that I got a faulty Amazon Echo device… or Amazon changed something in their firmware as it got updated this morning… just banging my head against the wall and not getting anywhere… :frowning:

The Echo devices will say no devices discovered if there are no NEW devices as well. Have you used the Alexa app to confirm that no Devices have been found?

What I did to solve my problems was to go on the website https://alexa.amazon.com and there under Smart Home deleted all devices as bulk. Then a new search discovered by devices and things worked well.

1 Like

Hello all,

I have another question regarding Hue Emulation and Alexa: what will happen if I have Hue Emulation running on OpenHAB and a real Hue Bridge in my house. Will they interfere or will Alexa just happily discover both and serve devices on both devices?

This is a fresh install and no devices ever been used/found in the past. I’ve double checked in the Alexa app on the phone as well as in web browser http://alexa.amazon.com.au/

What is the reason that you are port forwarding? Not required on an open network. Can you leave the port undefined and let the discovery happen normally?

As we’ve mentioned before, and I believe you have done, make sure Pairing Enabled is set to True.

Have you done a Port Scan on your own network?