Alexa can't discover new devices

I’ve had Alexa and Openhab setup for over a year without any issue, but the other day I added a new switch and Alexa can’t discover it.

The item is configured as below.
Switch Light_Garage_Voice_Trigger “Garage Light” [“Lighting”]

The log says the file was read without issue.
2020-09-26 16:59:40.503 [INFO ] [el.core.internal.ModelRepositoryImpl] - Refreshing model ‘garage.items’

The rest api ( does include the new item.

| --- | --- |
|label|"Garage Light"|

I also tried to delete an item from the Alexa app that was already working and Alexa can’t rediscover that item either.

I have tried removing the Openhab skill. When I did this, the Openhab items were still listed in the Alexa app but became unresponsive. This surprised me a little as I thought they would be removed entirely.
I readded the Openhab skill and the items that had already been discovered by Alexa came online again, but it still can’t discover new items (or the one I deleted as a test).

I was thinking it may be an Alexa issue, so I tried adding a new item to the Tuya skill and Alexa was able to discover that.

I’m out of ideas. Can anyone think of a possible reason for this?

I’m running Openhab on a Ubuntu 18.04 x64 vm.
The Openhab version is 2.5.9-1
My Java version is Java™ SE Runtime Environment (build 1.8.0_241-b07)

1 Like

Asking the obvious - you did turn on device discovery in PaperUI when asking Alexa to discover new devices.


Switch Light_Garage_Voice_Trigger “Garage Light” [“Lighting”]

Should look like

Dimmer LightDimmer "Light Dimmer" {alexa="Lighting", channel="mqtt:topic:myMQTTBroker:Kitchen_Bench_Light:dimmer" }
Color LightColor "Light Color" {alexa="Lighting"}

Dimmer LightDimmer "Light Dimmer" {alexa="PowerController.powerState,BrightnessController.brightness" [category="LIGHT"]}
Color LightColor "Light Color" {alexa="PowerController.powerState,BrightnessController.brightness,ColorController.color" [category="LIGHT"]}

@denominator Thanks for the reply. I tried that syntax too but have the same problem.
Specifically, I tried the following:
Switch testTrigger “Test Trigger” {alexa=“Lighting”}

I believe either syntax should work. At least, they use to anyway. :wink:

@KidSquid I haven’t. I don’t normally use the PaperUI and configure everything (except zwave) in text files.
In the past, all I’ve had to do was add either the “Lighting” or “Switchable” tag and a label?

I’ve had a Google and a look around the PaperUI and I can’t find a discovery option. Where can I find it?

I haven’t exactly found the problem, but I’ve found a workaround.
I have the following line in the same items file as the new switch.

Rollershutter   GarageDoor         "Garage Door"    <rollershutter>      ["Switchable"]  {alexa="RangeController.rangeValue" [category="GARAGE_DOOR", friendlyNames="@Setting.Opening", supportedRange="0:100:100", unitOfMeasure="Percent", actionMappings="Close=100,Open=0,Lower=100,Raise=0", stateMappings="Closed=100,Open=1:0"]}

I commented that line out and Alexa was able to discover Light_Garage_Voice_Trigger.

Uncommented it out and it wasn’t able to discover new devices again.

Specifically, commenting out the Alexa bit of the line fixes it, like below.
Rollershutter GarageDoor “Garage Door” [“Switchable”] //{alexa=“RangeController.rangeValue” [category=“GARAGE_DOOR”, friendlyNames="@Setting.Opening", supportedRange=“0:100:100”, unitOfMeasure=“Percent”, actionMappings=“Close=100,Open=0,Lower=100,Raise=0”, stateMappings=“Closed=100,Open=1:0”]}

Can anyone see anything wrong with that line?

By commenting that out, allowing Alexa to discover the new switch, then uncommenting the line, I’ve managed to get it working for the moment. It looks like I’ll need to comment out that line each time I add a new item to Alexa though…what’s particulary weird is, that line hasn’t changed for months.

Chris -

Are you using the Alexa binding or Hue Emulation?

I wrote that reply in the middle of the night and I should have prefaced my comment with this question.

You will only see the switch I am referring to with Hue Emulation.

Squid :squid:

I’m just using the Openhab Cloud Connector thingy.

I’ve found the issue. I changed:




and it’s all working again.

I don’t remember changing it, but I must have sometime between when I previously added the last item to Alexa and Friday.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.