Alexa doesn't find devices anymore

I run openhab 2.4 on a Raspberry 3+, openhabian distribution.

Starting yesterday (it worked fine for about a year or so), my echo dot and echo show stopped working with my openhab hue emulation. When I tried to use one of the voice commands, Alexa replied that the device does not respond. The echo control binding works fine.

Here is what I tried so far:

  • I cleared the list of devices through the alexa web interface, set the hue emulation via Paper UI in pairing mode and searched for devices again - the devices were found again, but no change in the reaction of Alexa to the voice commands

  • I reinstalled the hue emulation and restarted openhab – no change

  • I reset my echo dot (this had helped in the past when I had similar problems)

  • I deleted the devices from Alexa through the web interface one by one (the first time, I deleted them all at once). This time, when I tried to pair them again, Alexa did not find any of the devices that should be exposed by the hue emulation at all

Does anybody have a clue, what could have happened?

Hi Chris,

exactly the same here since yesterday morning.

Done same staps like you with same results on obenhabian (openHAB 2.3.0-1 (Release Build)) with rPi 2B.

Hopefully anyone can help us.

Thanks for the hint.

Does that mean, that changing to 2.5 will fix the problem? and if yes, can I change the version of the hue emulation while keeping openhab 2.4?

I don’t know, please try it. I’m not using the HUE emulation, I have a HUE bridge.

I’m not sure, but I don’t think so. You may find the answer through the search function.

Before using the 2.5 hueemulation, do your research and be sure you understand all of the changes and their implications. It’s been broken since poorly implemented and untested changes were pushed right before the 2.4 release, and it has gone down hill from there. Also, the 2.5 hueemulation will not work with 2.4.

1 Like

I use hue emulation on 2.5m1.

When I update to 2.5m2 I have issue. I plan on doing a git issue for the problem but I have not setup my test system to capture data yet.

I do use emulation on m1 though.