Alexa Echo TTS


Just installed Amazon Echo Binding. Everything works except TTS.

I am also missing the channel in paperUI for TTS

any hints?


best regrads

click on “Show more”

1 Like

i already have clicked on show more - still no tts channel

I guess you have the wrong binding version then.
That channel was added recently, so double check the correct binding.
If you are on 2.3 release you can install the binding directly through PaperUI, no need for manual added jars or installation through marketplace.
You could also try to delete cache and tmp and restart openHAB.

clear cache and tmp

i have this binding installed - still no tts

i will uninstall and retry

That did it :slight_smile:

Working flawless

1 Like

How do you use TTS?


String Alexa_TTS { channel="amazonechocontrol:echo:account1:yxyxyxyxyxyxyxyxyxyx:textToSpeech" }


Alexa_TTS.sendCommand("Whatever Alexa should tell you")

Doesn’t work for me.
Neither with the Echo dot nor the Alexa pi.

Check if you have that channel available at all (click “Show more”):


I’m at work rn, but the channel has always been online.
PaperUI via openhab connector says echo dot and Alexapi are currently offline, so I can’t tell atm, but I’ll update as soon as I get home.