Alexa Last Voice Command has changed

Tags: #<Tag:0x00007f6173296db0>

Hi everyone,

I recently noticed a change with Alexa “Last Voice Command”. I am on openHAB 2.5.5 release build and ver. 2.5.6.202006152137 Amazon Echo Control Binding.

When I would ask Alexa, “What’s my news briefing,” the “Last Voice Command” would trigger a timer to start. (When I wake up in the morning I take a pill and need to wait for 30 minutes before eating or drinking.) At the end of the timer openHAB would issue a TTS that it is time for coffee. About a week ago, it stopped working. Other commands like “what time is it” of “what is the weather” show up in the last voice command, but not what’s my news briefing. I should add, that my news briefing does start, jut doesn’t populate the last command item.

This is not a big deal, but wonder if others have noticed anything similar.

Thanks,
Chris

I’ve noticed a similar problem, which I thought might be related to another issue, posted here.

Essentially my tests suggest that there are certain phrases which LastVoiceCommand no longer reports, whereas previously it report every single phrase heard by the echo device. LastVoiceCommand does not get updated if phrases contain the names of smarthome items (I noticed it with lights, blinds, thermostats). Presumably this is also true of the news briefing you have set up. It doesn’t appear that the devices even need to exist in the openHAB or Alexa systems (for example, I don’t have blinds, and any phrase asking to control blinds does not update LastVoiceCommand. But ‘Alexa, volume up’, ‘what’s the time’ or even random phrases like ‘you’re beautiful’ will all get reported just fine! It’s very strange behaviour.

I’m running on openHABian on a RPi4, and was on 2.5.6 when this problem started a couple of days ago. I’ve since updated to the latest stable release 2.5.7 and tried various snapshots of the 2.5.7 EchoControl binding, but the problem remains.

I wonder if this is a security feature introduced by Amazon server-side. Whatever it is, it has broken some crucial elements of my smart home, so it would be good to hear whether others are having the same problem.

More findings on this. I went to “review voice history” in the privacy settings on the Alexa app, and it looks like Alexa is now programmed to ignore commands which are intended for other devices. See this screenshot:

In this example, my alexa centric commands are converted to text and therefore available under lastVoiceCommand, but where the command includes mention of a smarthome device (i.e. ‘lights on’ or ‘blinds up’), the voice history only states ‘Audio was not intended for this device’ (again, it doesn’t matter if the device even exists in the system). Interestingly, the audio itself is still there, and I can access all commands as normal by pressing the chevron.

It looks like Alexa redacts/stops processing any command which is deemed to not be directed specifically at Alexa.

I’m assuming this is all done server-side, so it seems unlikely that it can be resolved through the binding. Kinda breaks the endless possibilities of lastVoiceCommand :frowning:

I switched my trigger phrase from “what’s my news briefing” to “what’s my weather”. It worked for a day or two, but no more. It’s a real shame that this is not working anymore. I don’t understand why Amazon would change this.

Agreed. It has broken a ton of stuff in my setup and there is no decent solution which doesn’t involve comprehensive and reliable output of lastVoiceCommand.

I wonder if the AmazonEchoControl binding wizards @J-N-K, @Trinitus01 and @richaardvark are aware of this change, and whether anything can be done on the binding side to get full functionality back.

Hi,

did you test 2.5.8?
lastVoiceCommand works very well for me.
Also i found no issues in any way.

Edit: No i realised it depends on what to say to alexa, will check it.

br

Maybe i misunderstood the problem but i said something like “Alexa turn on the light” and it appears in the log as lastVoiceCommand. So is there anything i missed to reproduce the problem?

br

1 Like

Thanks for looking into it. I’ve just had time to update openHAB to 2.5.8-SNAPSHOT and it’s has solved the problem.

I’m not sure what was causing it, as I hadn’t made any changes to my setup in a few days and it simply changed overnight. I was on 2.5.6 Stable, and updated to 2.5.7 to try to fix it.

Following your message, I backed up my conf files, etched a fresh copy of openHABian to my RPi4’s SD card, and then updated OH to 2.5.8, and bingo, we are back in business! I’d rather not be on a snapshot release for daily use but lastVoiceCommand is pivotal in my system so…

Thanks again for pointing me in the right direction.

1 Like

Where can I download the 2.5.8 snapshot of Amazon Echo Control Binding. I have looked around and cannot find it. I did upgrade to 2.5.7 stable release of openHAB, but don’t want to run the snapshot of the rest of the system.

Thanks,
Chris

You might try http://readme1st.de/tom/downloads/org.openhab.binding.amazonechocontrol-2.5.8-SNAPSHOT.jar
Tom postet it somewhere else.

You can always find the latest snapshot addons.kar by going to openHAB.org/download > select your OS and the latest snapshot build > follow the link in the ‘manual installation’ section > scroll down in Jenkins to find the ‘last successful artifacts’, which will include the openHAB.tar.zip and separate ‘addons’ files.

Just drop that in your addons folder and you’re away!

Thank you Marino.

Unfortunately, running ver. 2.5.8.202007261149 of Amazon Echo Control Binding did not fix my issue. Some commands like set a timer does populate Last Voice Command, but not what’s my news briefing.

That’s weird. Perhaps the fact that I did a full reinstall fixed a conflict between the binding and openHAB jsondb.

What’s your setup? I work almost entirely with conf text files, so reinstalling from scratch isn’t as drastic as it might be on a GUI/database-heavy installation. Are you able to make a complete backup of your system and experiment with a full install of the latest snapshot?

I use text files as much as I can for my configuration. I think my next move is to install the latest snapshot version on my test Raspberry Pi and see how that goes.

The “Last Voice Command” started working for me. I didn’t change anything since yesterday. Weird.

Looks like Amazon changed something.
The history did not show Smart-Home commands some days ago in browser.
Checking the history today shows also Smart-Home commands that were executed some days ago.