ALEXA vs. Eurotronic Comet DECT for Fritz!BOX

fritzbox
avmfritz!binding
alexa
Tags: #<Tag:0x00007f0152909570> #<Tag:0x00007f01528fe148> #<Tag:0x00007f01528fc320>

(Dennis Lang) #1

Hello Guys,

at the moment I work on the integration of the Heating Thermostat in ALEXA - Till now I am able to control the Temperatur on all 7th Thermostat and can ask for the current temperature.

This commdos are Working (translated from German):
ALEXA, set Temperature of Bathroom Heater to xx°C
ALEXA, increase/decrease temperature fo Bathroom Heater about 5°C
ALEXA, what is the Temperature of Bathroom Heater?

The Item Group look currently like:

Group BadThermostat "Badezimmerheizung" ["Thermostat"]
Number BadThermostatCurrentTemp "Badezimmerheizung Aktuelle Temperatur" (BadThermostat) ["CurrentTemperature"] {channel="avmfritz:Comet_DECT:192_168_178_1:119600066888:temperature"}
Number BadThermostatTargetTemperature "Badezimmerheizung Soll Temperatur" (BadThermostat) ["TargetTemperature"] {channel="avmfritz:Comet_DECT:192_168_178_1:119600066888:set_temp"}

But is it also possible to set the Mode (ON, OFF, ECO, COMFORT and BOOST) via ALEXA or ask for the currently set target Temperature? If yes how can I realize it?

Thank you in advanced


(Dennis Lang) #2

Has nobody any idea?


(Christoph Weitkamp) #3

Dear Dennis,

first if all, I have absolutely no clue how the setup for Alexa has to be done. But because you want to use it together with avmfritz binding, I am interested very much in figuring out a possible solution.

Did you look at the documentation for the homekit setup: http://docs.openhab.org/addons/ios/homekit/readme.html#item-configuration

There seem to be a third item - HeatingCoolingMode - which has to be added to the Group for your thermostat. Additionally there seem to be a configuration to customize the mapping of the different HeatingCoolingMode modes. Maybe that is the way to go. E.g.:

demo.items

...
String BadThermostatHeatingCoolingMode "Badezimmerheizung Modus" (BadThermostat) ["homekit:HeatingCoolingMode "]{channel="avmfritz:Comet_DECT:192_168_178_1:119600066888:radiator_mode"}

demo.cfg

...
org.openhab.homekit:thermostatCoolMode=ECO
org.openhab.homekit:thermostatHeatMode=COMFORT
org.openhab.homekit:thermostatAutoMode=AUTO
org.openhab.homekit:thermostatOffMode=OFF
...

Be aware of typos. I wrote this down in a second.


(Dennis Lang) #4

Thank you for you support, but this i had already tried, but my third item looks a bit different. Nevertheless i also tried your syntax, but it stills that Alexa said, that she don’t know how she can set this for the Heater.

But many thanks, that you tried to help me, without glue with alexa :slight_smile:

Greetz
Dennis


(Christoph Weitkamp) #5

Alright. Sry. Let me know, if you find a way to solve this issue.


(Christoph Weitkamp) #6

I just found this post: Alexa and Heating/CUL Problem. Did you test that?


(Alex) #7

@deladus

“…the Alexa skill expects the thermostat mode item (“homekit:HeatingCoolingMode”) to conform exactly to the strings “OFF, HEAT, COOL, AUTO, heat-cool” or “0,1,2,3”. […]”. See here link

But you can realize this via rules. I have done this. But I have to look it up, when I’m back at home.


(Michael Bartmann) #8

Maybe you can use Proyxy Items to influence Alexa. Alexa can control any “Switchable”.
So when you want to change an arbitrary Item “ItemX” with states “A”, “B” and “C”, you could setup unbound Proxy Switch Items in openHAB like:

    Switch ItemX_State_A "X state A" ["Switchable"]
    Switch ItemX_State_B "X state B" ["Switchable"]

and rules

rule "set ItemX to state A"
when
   ItemX_State_A changes to ON
then
   ItemX.sendCommand("A")
   ItemX_State_B.postUpdate(OFF)
   ItemX_State_C.postUpdate(OFF)
end

// and so on

Then you tell Alexa “turn X state A on”.

Maybe not intuitive for others, but it should work.


(Alex) #9

@deladus

Maybe this could also help you: see here Link


(Dennis Lang) #10

Hello thanks for your tipps but nothing is working if I say “Alexa, set Heater in Sleepingroom to comfort” she say “i don’t know how I can make this setting”


(Dennis Lang) #11

Hello again,

so now I update my Items like this:

Group BadThermostat "Badezimmerheizung" ["Thermostat"]
Number BadThermostatCurrentTemp "Badezimmerheizung Aktuelle Temperatur" (BadThermostat) ["CurrentTemperature"] {channel="avmfritz:Comet_DECT:192_168_178_1:119600066888:temperature"}
Number BadThermostatTargetTemperature "Badezimmerheizung Soll Temperatur" (BadThermostat) ["TargetTemperature"] {channel="avmfritz:Comet_DECT:192_168_178_1:119600066888:set_temp"}
String BadThermostatHeatingCoolingMode "Badezimmerheizung Modus" (BadThermostat) ["homekit:HeatingCoolingMode ** "]{channel="avmfritz:Comet_DECT:192_168_178_1:119600066888:radiator_mode"}

Now I can also Ask: “Alexa how is Bathroom Heater set to?” in German: "Alexa, wie ist die Einstellung der Badezimmerheizung?"
Alexa answer: “Unkown Modus is set to xx°” <- Means the currently set degrees

BTW also if I say "Alexa, set Bathroom Heater to xx°"
Alexa is answering “Unknown Modus is set to xx°” <- Means the new/adjust degrees

It is not very pretty, that the Mode is unknown for Alexa - but it works! Has anybody new experiences to teach Alexa, what “unkown modus” is?

My configuration of Homekit:


(Killercorny) #12

I´ve got problems too with this thermostat. My items:

Group gCOMET “Badezimmer Heizung” (gCOMET) [ “Thermostat” ]

Number COMETActualTemp “Temperatur [%.1f °C]” (gCOMET) [ “CurrentTemperature” ] { channel=“avmfritz:Comet_DECT:192_168_111_1:119600710344:actual_temp” }
Number COMETSetTemp “Ziel-Temperatur [%.1f °C]” (gCOMET) [ “TargetTemperature” ] { channel=“avmfritz:Comet_DECT:192_168_111_1:119600710344:set_temp” }
String COMETMode “Geräte-Modus” (gCOMET) { channel=“avmfritz:Comet_DECT:192_168_111_1:119600710344:mode” }
String COMETRadiatorMode “Heizungs-Modus [%s]” (gCOMET) [ “homekit:HeatingCoolingMode **” ] { channel=“avmfritz:Comet_DECT:192_168_111_1:119600710344:radiator_mode” }

I cant set the temperature. When I say (in german) “Alexa, set Bathroom temperature to 20 degree”, it answers:
“Automatic mode ist set to 20 degree.” The target temperature (“Ziel-Temperatur” item) doesnt change.
Is this a common problem, or just a small error in my config?


(Dennis Lang) #13

Where do you check, if the “Ziel-Temperatur” is not change? This part of my installation is working very well. But you have to keep in mind, till the new settings reach the Themostat, can be up to 15 Minutes! Because this is the interval with which the FritzBox is communicate with the devices!

On my side: in OpenHAB i see the changing directly. In the FritzAPP2 also, but on the Thermostat it spends some minutes! Exception: If the Display is dark and I press the botton in the middle to wake up. After that I can see that the device is changing from the old stetting to the new setting.

If your problem Still, please check your openhab.log and event.log, wat happen!


(Killercorny) #14

I checked the target temperature in the OH2 GUI. In the meantime I´ve tried something else:

String COMETRadiatorMode "Heizungs-Modus [%s]" <heat_mode> (gCOMET) [ "homekit:HeatingCoolingMode **" ]

its the same therm but without the channel and there´s a strange effect: when I set a temperature to a value via Alexa its also set in the GUI, but after a few seconds the temperature is set back to the old value… :expressionless:


(Dennis Lang) #15

This string is not needed to set the Target Temp!

To set the Target-Temp you need this Item:

Number BadThermostatTargetTemperature "Badezimmerheizung Soll Temperatur" (BadThermostat) ["TargetTemperature"] {channel="avmfritz:Comet_DECT:192_168_178_1:119600066888:set_temp"}