Amanda Server not responding

Sorry if I’m missing key info here, I’m new to openhab and linux and I’ve barely made it past getting a lightswitch to turn on and off.

I’m trying to set up Amanda backups through the openhabian configuration. I’m running the lastest 2.4.0 (I think?) on a Ubuntu 18.04 Dell Optiplex.

I mounted a 32GB USB stick, pretty sure I got the fstab configurations correct, to /media. I made it through the Amanda configuration in openhabian (I elected not to have it back up my SD card, since I’m assuming that means my entire partition which is well over 16GB), and allocated 2GB for the backups. I think everything is configured correctly… I can see the slot directories it created in /media, and I can access them as the backup user, but when I run amcheck openhab-dir, I just get the “Amanda Tape Server Host Check” header and it never prints out any other info. I tried amdump openhab-dir and let it sit for about 5-10 minutes and it never returned. Not sure what/how to diagnose that?

Check the logs in /var/log/amanda if they give any hint.

I checked the log files. The log file didn’t appear to have anything regarding the amcheck run, but I did try an amdump and it logged that, as well as logging that I ctrl+C’ed my way out after awhile, but there are no timestamps to indicate if it hung during any particular part of that.

There’s also an amdump.1 file that appears to report that it’s set up a scheduled backup of my openHAB directories, but I’m not cron savvy enough to figure out when it will run, I’ll probably just need to keep tabs on the slot directories and see if anything shows up.

Update: I let amcheck run for as long as it wanted. I don’t really know when it finally came back, but it finally produced results.

ERROR: Timeout trying to lock '/media/slots/state': Permission denied

I don’t even see the state file in the /media/slots folder, not sure how to fix this one?

Your storage (i.e. /media/slots) has to be at least group-writeable for the backup user/group as written in the docs.

also see docs

Thanks Markus, that’s definitely the issue! I cleared out the files on the USB stick and remounted using the fstab entry for FAT32 (as per the docs), then re-ran the openhabian configuration, but I think I might have missed something. I see a bunch of chown: changing ownership of '<slot dirs>': Operation not permitted. I double checked the fstab entry and made sure the drive is mounted correctly, but the backup user still doesn’t have the correct access.

Should I reformat the usb stick for ext4?
EDIT: I reformatted the usb stick for ext4 and used the instructions in the docs for the usbstick-linux. Worked like a charm! I’m in business now.