Amazon Alexa Binding Login

Hi

I installed the Alexa Binding want to link my Amazon Credentials to http://<OPENHAB-IP:8080/amazonechocontrol/850366bf/

I can login and I receive a SMS for Approval. But I have not enough time to do this. The page reloads after a few seconds. I tried other Internet Browser, run Updates, run Browser in privacy mode. Reinstalling…No chance to get it working.

I run Openhab with Openhabian on a Raspberry PI with version 2.5.10

Anybody here for helping?

Thanks a lot.

Enable the 2FA / two step verification in your amazon account settings:
German version: https://www.amazon.de/gp/help/customer/display.html?nodeId=202013020
English version: https://www.amazon.com/gp/help/customer/display.html?nodeId=202073820

1 Like

As @Wolfgang_S suggested, enable 2 factor authentication on your amazon account , this way you won’t experience that page redirection issue

I don´t know if I understand it wrong but my 2FA is activated because I need a Code which is sent by SMS to login.
The problem is that openhab gives me not enogh time to approve the login. I tested it with SMS and Authenticator App in my amazon account.

I have it.
Thanks a lot Radu_Marius and Wolfgang_S.
I found the right option now and it works.