Amazon Dash Button as openHAB Trigger

Thanks for this plugin, Oliver! It works really good. The only difficulty for me was to figure out how the trigger event is used in the rules. So I made the same mistake as Steve when the documentation was not yet updated. With the new example it’s much clearer now.

The only thing that remains a bit unclear to me is the ability that I can bind an item to this channel. Does this have any effect or it it ignored completely?
If it’s ignored, is it possible to prevent the linking ability so that users do not get confused by that?

Moreover since this plugin uses an undocumented OH feature (channel event), I assume that every user needs to read the binding documentation in order to get it work. What about placing a link to the binding documentation in the thing or binding description shown in the paperui? Actually, I wish this would be a default for all OH plugins. :wink:

Anyway, thanks a lot for your work on this plugin! is updates now.

Hi. Did anyone experienced with Amazon IoT Button ?
It should have same hardware as Dash button, but from description it should talk MQTT, and all you need is to make it somehow publish topics on your MQTT broker instead of AWS. But basically for original use as remote controller it should be fine to use AWS - AWS is acting like fast MQTT broker, to which OpenHab could be connected as well.
Worth to try?

I looked at them when they first came out but they sold out too fast. It would be nice to have one that talks to MQTT directly (eliminates the lag with the Dash button right now).

At $20 I personally would only consider it if it had a relatively easy user replaceable battery. $20 is too much for something disposable. However, with the new Amazon Dash Binding it is possible to get something that works well for $5.

Hi Oliver,

thanks for your binding. Looks promising. However, I think I have problems getting it to work properly as I don’t get any things in the inbox when I press the dash button.
The situation looks quite well

  • OH2 running on raspbian, Raspberry Pi 2
  • amazondash binding installed and runs properly; I see the binding in the paper UI
  • libpcap-dev is installed in raspbian
  • setcap is set as you described: sudo setcap cap_net_raw,cap_net_admin=eip realpath /usr/bin/java
  • dash button is configured in the network
  • I see the arp requests on my PC with wireshark
  • I see the arp requests on the raspi with tcpdump
sudo tcpdump -i eth0 arp and ether host XX:XX:XX:XX:XX:XX -l
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 262144 bytes
21:15:02.608080 ARP, Request who-has tell, length 46
21:15:16.103170 ARP, Request who-has tell, length 46
  • I don’t see any messages in the log from your binding though
  • no new things in the inbox
    Any hints what could be wrong? How can I make sure the binding can correctly use the libpcap?



do you use the latest version of the binding? I fixed a bug some days ago:

Kind regards

1 Like

Ah, ok, I now installed the latest Snapshot build 173. Now it works. Thanks!

Hey Oliver, got a problem with the dash binding, it’s trigger only sometimes and there has to be something about 15 minutes between the pressing to trigger.

Please check properties of your amazondashbutton:dashbutton:XXXX Thing and make sure that property called “Packet processing interval (in ms)” is set around 5000. Dash needs to wait some time until it stops flashing red.

Also, please check if there’s anything in openhab.log file.
If there’s an issue with the binding, you can submit an issue if there wasn’t already.

in the openhab.log is nothing about the dash button.
in the event.log is 90% of the button press only this message:
2016-12-02 20:27:35.229 [ThingUpdatedEvent ] - Thing ‘amazondashbutton:dashbutton:ac-63-XX-XX-XX-XX’ has been updated.
2016-12-02 20:27:35.849 [ThingUpdatedEvent ] - Thing ‘amazondashbutton:dashbutton:ac-63-XX-XX-XX-XX’ has been updated.

and I can’t change the “Packet Processing interval” because in the PaperUI the thing screen is empty after the header Channels

Update: Issue fixed:
I just removed the exising dash button from the things list.
That one was added using the auto discovery.
After that I added the button again manually.
I noticed that the identifier changed:
Before: "amazondashbutton:dashbutton:XX-XX-XX-XX-XX-XX:press"
After: “amazondashbutton:dashbutton:bfa71339:press”

The one I added manually is consistently recognized in the rule file.
Thanks for reading.

Happy new year everyone!

First of all: I just started a couple of days ago with OH.
My first goal is to make good use of the dash button :slight_smile:

My girlfriend can use the button downstairs and a LED notifies me upstairs in my office.

I have the German Dash button (never version I guess).
What I got so far:

  • Dash button recognized successfully and I receive the following log entry:
    [ChannelTriggeredEvent ] - amazondashbutton:dashbutton:XX-XX-XX-XX-XX-XX:press triggered

I added the rule exactly as Oliver wrote in this documentation:
rule "Dash button pressed2"
Channel “amazondashbutton:dashbutton:XX-XX-XX-XX-XX-XX:press” triggered
logInfo(“rob.rules”, “In rule lightsOn”)
println(“The Dash button has been pressed”)

My issue:
The ‘then’ part is not reached.

I verfied that the rules file is called correctly by just adding a simple one (every minute):
rule "dummy"
Time cron "0 0/1 * * * ?"
logInfo(“rob.rules”, “TimeTriggered”)

What am I missing here?

Btw: The LED (GPIO on Raspberry PI/OH server) can be triggered correctly via the UI.

OpenHab2 version: 4.0.8
Dashbutton binding: binding-amazondashbutton - 2.0.0.b5

If have a new button which does not get detected.
I found that if I use to post to the OpenHab REST API my device works for a while.

It seems that the new buttons if they cannot connect to Amazon stop working locally.
Has anyone seen this with the new buttons ?

See also my post here:

Is there any ideas on how one would be able to adapt this to work in Docker containers? I’m running OH in a container, and while I could go the route of manually installing the LibPCAP, any time the containers is updated and restarted - I will lose this functionality.

Is it possible in any way that maybe we can add in the LibPCAP to the docker install and setup? Should I be posting to that topic instead perhaps?

Open a feature request issue on the openhab-docker github.

Done! #85

Hello everyone,

can somebody help me to get dash buttons discovered in the paper ui?
I followed the binding documentation but it is not showing up in the inbox even if i press it while the binding is scanning for new devices.

If i add the device manually, the thing status is “Offline” The capturing for eth0 cannot be started. Sounds like a rights problem, but as i said i followed the whole doc.

I am running the latest OH2 snapshot and it worked before in the OH2 release, but not anymore.



same issue here.

Hello everybody,
I have installed libpcap-dev on my Synology NAS (DS216j) with optware-ng for the Amazon Dash Binding. Unfortunately setcap cap_net_bind_service on DS 6 is not supported.
Synology Support wrote:
Unfortunately the setup of Privileged Ports is not supported on our systems, since this is associated with an intervention on the system level.
Is there another way to run Pcap4J with a non-root user to my java command?
Best regards

Have you attempted/managed to get this working with openHAB2? I suspect that it’s still possible but of course not with the depreciated CMD call.