Amazon Dash Button

Hi …
I’ve just bought 3 Amazon Dash Buttons from EBay.
I was aware that Amazon no longer supports the hardware dash buttons … only the virtual dash buttons. But I thought I would be able to connect my hardware dash-button to my WLAN and use them in openHAB as a trigger / switch. Seems like there is no way to use them … or?

Thank you very much for your help!


It depends on your version.

But you can try:

First of all disconnect your router from Internet or block all devices to get into internet.

Press the dash button for 5 seconds til it’s blinking blue.

Connect your notebook/pc/smartphone to wifi with SSID: “Amazon ConfigureMe”

Open a webbrowser and paste this url:

where SSID is your local wifi and PASSWORD is your wifi secret.

After this press your button once.

Then determine MAC-ADDRESS or IP-ADDRESS of your dash button. Block it for Internet access in your router settings.

If done, connect your router to Internet again (or unblock your formerly blocked access)

1 Like

Hi Alex …
thank you very much for your help.
I was able to connect to the WIFI “Amazon ConfigureMe”.
In my browser I opened the URL to configure the device with my WLAN-Settings (SSID / PWD).
After that I pressed once the button …

When I open the URL I see the following data …

But when I’m searching for a new Amazon Dash Button Thing in the PaperUI I’m not able to find it.

You have to block also your DashButtons from accessing Internet in your router settings. Either block MAC-ADDRESS or IP-ADDRESS of your dash button.

Read my first post again. Do all steps.

If this doesn’t work, your firmware is too new or the dash button was bricked by Amazon before.

You also could read this manual or try this python script.

Hi Alex …
thank you very much for your reply.
I’ve tried the audio exploit, but didn’t get a green light.
Altough tried the script … this works fine and I’ve got the message “Dash button configured!”.

Added the dash-button as a thing to my openhab … MAC-address in format xx-xx-xx-xx-xx and also in xx:xx:xx:xx:xx network interface “eth0”.
Copied the rule from the binding documention … but didn’t get a trigger event after pressing the button.

Is there a way to check if the firmware of the dash button is “to new” or if the dash-button has already been bricked from amazon?

Thank you very much and best regards … Marco


Normally you do not need to configure a .things file. But you could.

Please go to PaperUI --> Inbox --> + --> Amazon Dashbutton

Then press your button.

It should get detected automatically. Now you can add this as a thing.

If this is not running, then it could be that firmware is too new or it was bricked.

How to find out?

Audio exploit is running until 4xxxxxxxxx.

If bricked? Sorry, I don’t know.