Amazon Dot (Alexa) not finding devices

i have a few devices configured for Alexa, but it seems to have stopped discovering them

Switch KitchenLamp "TV Lamp" <light> ( Lights, GF_Kitchen, GF_Kitchen_Lights, gGF ) {mqtt=">[broker:cmnd/sonoff9/POWER2:command:ON:1],>[broker:cmnd/sonoff9/POWER2:command:OFF:0],<[broker:stat/sonoff9/POWER2:state:default]"}
Switch KitchenTV "TV" <screen> ( GF_Kitchen, gGF ) {mqtt=">[broker:cmnd/sonoff9/POWER1:command:ON:1],>[broker:cmnd/sonoff9/POWER1:command:OFF:0],<[broker:stat/sonoff9/POWER1:state:default]"}
Switch KitchenLEDS    "Worktop LEDs"            <light> ( Lights, GF_Kitchen, GF_Kitchen_Lights, gGF )    {mqtt=">[broker:cmnd/sonoff8/power:command:ON:1],>[broker:cmnd/sonoff8/power:command:OFF:0],<[broker:stat/sonoff8/POWER:state:defa$

Switch DownstairsToilet             "Downstairs Toilet"       <light> ( Lights, gGF )    {mqtt=">[broker:cmnd/sonoff12/power:command:ON:1],>[broker:cmnd/sonoff12/power:command:OFF:0],<[broker:stat/sonoff12/POWER:state:default]"}
Switch CallumsLight             "Callums Light"       <light> ( Lights,TF_Callum,  gTF )    {mqtt=">[broker:cmnd/sonoff48/power:command:ON:1],>[broker:cmnd/sonoff48/power:command:OFF:0],<[broker:stat/sonoff48/POWER:state:default]"}
Switch RhiansLight             "Rhians Light"       <light> ( Lights,TF_Rhian,  gTF )    {mqtt=">[broker:cmnd/sonoff49/power:command:ON:1],>[broker:cmnd/sonoff49/power:command:OFF:0],<[broker:stat/sonoff49/POWER:state:default]"}
Switch AmysLight             "Amys Light"       <light> ( Lights,TF_Amy,  gTF )    {mqtt=">[broker:cmnd/sonoff47/power:command:ON:1],>[broker:cmnd/sonoff47/power:command:OFF:0],<[broker:stat/sonoff47/POWER:state:default]"}

Ive added the last 3 on the list today and non are discoverable.

Also I was having an issue with a device so deleted it out of alexa and tried to rediscover but it didn’t find it.

Any Ideas?


First, the line starting “Switch KitchenLEDS” has a strange ending (defa$) - if this isn’t a copy/paste error, you should corret this.

Second, You need to tag the Switches as described in Official Alexa Smart Home Skill for openHAB 2.

Thanks. $ was because the line went over the edge of the screen. I’ll take a look at that documentation

Firstly the link in the tutorial is broken.

Secondly I dont have any items in (Is that correct )

But in the openhab app I have a number of devices, of which most work OK

You need to define items available to myopenhab
You can do this in the configuration/services section of the paperui.
Once you’ve told it what can be shared to the myopenhab cloud, and they are tagged correctly then the echo should see them.

Indeed? No matter if I define items to be available in the Cloud Connector, they do notshow up in Alexa…

Sounds obvious, so you may have tried, but have you tried to re-authorise the openhab alexa skill?

I had to re-install everything - the items showed up without listing them in the “Items to expose to apps such as IFTTT” field :wink: