Amazon Echo - Alexa don't find any devices

As many users, i had the problem, that my “echo” won’t find any devices. I tried many things to get the integration work.
Now, it’s done.
If anyone has this same problem, just check on which device you’re openhab server is connected. The “echo” is sending UPNP Packages into your network. For example, if you’re openhab device is connected to a switch, it’s possible that those packages were dropped by them.

My openhab server we’re connected to a small d-link switch, which is connected to a fritzbox. Everytime i told alexa to search for devices, only my hue lamps were found, but no openhab items. So i plugged the openhab raspi directly to the fritzbox and every item was discovered from alexa immediatly.

Once the echo has recognized the items, i could reconnect the server to the switch without any problems.
Now, i can talk to my house :slight_smile: … it’s amazing…

1 Like

Hi Mark,

i have still the problem that i don’t find any items. But my echo was able to find the Hue emulation items. Are those not found via the same UPNP protocol?


Hi Jens,
both use UPnP Packages.
@markee’s issue was that his openHAB server was connected via a switch, but his hue bridge seemed to be directly connected to the fritzbox. That’s why the hue devices were found, but not openHAB.
I guess, that this doesn’t solve your issue (unless you are also using a switch).

Hi Hans-Jörg,

i am using several switches to be honest :wink: But as i said, Hue Emulation (from OpenHAB) was found without any issues so i guess UPNP packets are not being dropped between Alexa and OpenHAB.


That’s why I said that this will not solve your issue. I hope to find some time tonight to dig into this.

Funny thing, I sent @jensen here, but I’m facing the same issue… I have one switch, connected to it some NAS, one of the running openhab on a virtual machine. Furthermore I have one Wifi AP per floor connected to the same switch, and Alexa didnt find my openhab devices (which show up fine in myopenhab). So i decided to connect the openhab NAS directly to the AP where one of my Echos is connected to, but still it doesnt find my devices. Hue bridge is connected via cable to another AP, so going through the switch, but hue devices are found, openhab devices are not found…

i think it is not a Network Configuration Problem.

I install iobroker, the software has also a alexa skill,
on the same server, where openhab is installed.

alexa found the items from iobroker.
so i think it is not a network protocol problem.

I figured out why it was not working:

i had a Thermostat configured:

Group   gHeizungSchlafzimmer      [ "Thermostat" ]
Number  Schlafzimmer_Heizung_temp_soll          "Solltemp Heizung Schlafzimmer"                 <temperature>   (persistHour,gHeizungSchlafzimmer)  [ "TargetTemperature" ]     { channel="homematic:HM-CC-RT-DN:1:MEQ0575659:4#SET_TEMPERATURE" }
Number  Schlafzimmer_Heizung_temp_ist           "Temperatur Schlafzimmer"                       <temperature>   (temperatur,gHeizungSchlafzimmer)   [ "CurrentTemperature" ]    { channel="homematic:HM-CC-RT-DN:1:MEQ0575659:4#ACTUAL_TEMPERATURE" }

After removing this, eveything was found perfecly well.

But why? I thought Thermostat is supported

According to the docs, the Thermostat group needs all tags, you might be missing a string item tagged “homekit:HeatingCoolingMode”

The switch i use to connect the raspi has firewall features included. So it’s possible that one of the security features dropped the UPNP Packages (but the huehub is also connected to this switch and hasn’t this issue), Anyway,… now it’s working fine

@MAX1968 …habe you checked, if the WiFi AP’s have UPNP enabled ? In my fritzbox i had to enable this feature.

they have upnp enabled. I had not tagged my items correctly however, had the tags at the end of the lines which doesnt work, it has to be before the curly brackets… Now at least I can see them correctly tagged through myopenhab REST API, however Alexa cant find them. I just started all over again, deleted all the tags I already made and createdjust a single test switch, no avail. However it might still be an upnp network issue as i have multiple alexas and i’m not sure which one is doing the discovery, some are still connected through the switch. Unfortunately just last week i said good bye to an old hub I still had and i thought i didnt need anymore, it is a bit complex to really eliminate the switch from my network now, will need some time…

BTW, how is the device recovery working ? As I have to expose the items to myopenhab, tag them correctly and grant Alexa access to myopenhab, is discovery working just through myopenhab or is it really using the local network at all ?

That is not needed …

I have no idea why, but it seems to be working now… i plugged everything back to my switch (no avail), and then due to some other stuff restarted openhab. Just checked Alexa by chance, and my testswitch is showing up there… but really no idea why :slight_smile:

Correction: It works now because I also installed the hue emulation binding… So hue emulation is able to find the device, while alexa skill is not able… I think it might be something different then network issue in this case ?

1 Like

hmerk, I’ve seen you understand the way integration between Alexa and OpenHAB works. I am having issues to get Alexa to find my items. I’ve installed openhab cloud and hue emulation miscelaneous addons, tagged items with “Switchable” and “Lighting”, configured openhab cloud to expose my items through openhabcloud.cfg file (which i created myself) and Paper UI as well. Linked Alexa, but Alexa just can’t find them. My files are below:

My Items: fan.items and lamp.items:

Switch fan "Fan" [ "Switchable"  ] {mqtt=">[mosquitto:esp8266/pincmd:command:ON:1],>[mosquitto:esp8266/pincmd:command:OFF:0],<[mosquitto:esp8266/pincmd:state:ON:1],<[mosquitto:esp8266/pincmd:state:OFF:0]"}

Switch Lamp "Sonoff" [ "Lighting" ] {mqtt=">[mosquitto:cmnd/sonoff_2/Power:command:ON:1],>[mosquitto:cmnd/sonoff_2/Power:command:OFF:0],<[mosquitto:cmnd/sonoff_2/PowerOnState:state:ON:1],<[mosquitto:cmnd/sonoff_2/PowerOnState:state:OFF:0]"}

My openhabcloud.cfg file:

# A comma-separated list of items to be exposed to external services like IFTTT.

# Events of those items are pushed to the openHAB Cloud and commands received for
# these items from the openHAB Cloud service are accepted and sent to the local bus.

# Optional, default is an empty list.

My addons.cfg file:

# A comma-separated list of miscellaneous services to install (e.g. "myopenhab")
misc = hueemulation,openhabcloud

Any hints here? I am stuck for days now.
Thanks in advance.

Hi Eduardo,

I don’t know if I understood the integration, or if it was just luck, but what I can say, I followed the docs.
So here is what I can see reading your post and configs.

  1. You don’t need to expose any item, using hueemulation you don’t need openhabcloud at all.
  2. Your first item has two spaces at the end of the tag.
  3. I am not shure if I did, but it might be worth to set huemulation to pairing mode before the first discovery initiated by Alexa.

I did all. Still not working. I am using the Alexa on Raspberry Pi. Is this okay for the integration?

I don’t have a clue, as I just have an Amazon ECHO and a DOT, both running fine.

It worked now! But I am not sure what I did. It seams that once it is linked it works perfectly, but until them it is a bit unstable.

I’m having a similar problem, my Echo cannot seems to discover all of the devices on my system. It can discover the first item in my .items file, but nothing more. I have confirmed that UpNP is working on my AP. I think the culprit is a syntax error in my .items file. The configurator is complaining “missing OEF at ‘<’” (referring to the room2LampsProxy item). Here is what I have:

//Family Room lamps
Switch room2LampsProxy "Light" ["Switchable"] <light> 
Switch room2SwitchA {mqtt=">[mosquitto:/home/room2/switchA/out:command:on:1],>[mosquitto:/home/room2/switchA/out:command:off:0]" }
Switch room2SwitchB {mqtt=">[mosquitto:/home/room2/switchB/out:command:on:1],>[mosquitto:/home/room2/switchB/out:command:off:0]" }

//Patio Lights
Switch pergolaLights "Lights" ["Switchable"] <light> {mqtt=">[mosquitto:/home/patio/pergolaLights/out:command:ON:1],>[mosquitto:/home/patio/pergolaLights/out:command:OFF:0]" }

Any suggestions?