Amazon Echo Binding not working on OH 2.5.8


I just upgraded to OH 2.5.8 but now the Amazon Echo Things don’t go Online.
I always get the error:

2020-08-26 18:38:43.577 [hingStatusInfoChangedEvent] - ‘amazonechocontrol:account:135801ce’ changed from OFFLINE (CONFIGURATION_PENDING): Wait for login to OFFLINE (COMMUNICATION_ERROR): POST url ‘’ failed: Bad Request

Any Idea, what I can try?

I upgraded today, to get the Amazon Echo Binding back online I had to use the"forgot password" function of amazon. That way a new password is created.

That fixed it for me also

Thx, fixed it for me too. I had to use the forgot password function direct from Amazon Account. The provided from OpenHab did not work.

That’s what I meant to say, obviously I was not understood in that way.

I’m trying to update my password, but the resulting webpage sends me a two-factor authentication, but I can’t receive it and acknowledge it before it boots me back to the login screen (about 3 seconds). Anyone else have this problem?

I changed the password successfully at directly, not on this authorization page.


Having same issues as above. Reset password via amazon direct. Still having same error loop. boots back to the login screen (about 3 seconds). when accessing

Running on RP 4 with openhab 2.5.8 as well.

Same problem here…

Same problem with me, some1 found a way to get it fixed ?

Found a way to login:
Go to your account and enable 2FA. Then go and try OH login to the device. It should work.

1 Like

Thanks, done and working also with Autentificator App.

All working. thanks. Enable 2FA via Then . Followed login with 2FA . web screen came back.
In paperUI. devices are back online no errors.

1 Like