Amazon Echo Bridge Installation Help

I’m having trouble installing the Amazon Echo Bridge for Openhab.

Whenever I execute java -jar amazon-echo-bridge-0.2.1.jar --upnp.config.address= --server.port=8081 to install the Amazon Echo Bridge, it boots up Spring Boot fine, but it starts spitting out errors:
2016-02-04 10:15:30.959 WARN 1624 --- [ main] ationConfigEmbeddedWebApplicationContext : Exception encountered during context initialization - cancelling refresh attempt
2016-02-04 10:15:31.073 ERROR 1624 --- [ main] o.s.boot.SpringApplication : Application startup failed

Afterwards, I cannot access the configuration.html to setup my Amazon Echo. I’ve tried restarting my Raspberry Pi and that didn’t work. Not sure what to do. Any help is appreciated. Thanks!

I figured it out. I had to change the permissions of the folder so it can run the operation correctly. It was set to root root. I changed it to pi root and that seemed to work.

Now, I’m running to a different issue this time after running -jar amazon-echo-bridge-0.2.1.jar --upnp.config.address= --server.port=8081. It’s not throwing any errors this time, but it seems like it’s stuck here:

2016-02-05 05:31:37.693 INFO 27566 --- [nio-8081-exec-8] c.armzilla.ha.upnp.UpnpSettingsResource : upnp device settings requested: amazon-ha-bridge from

It stop for a few seconds and show this again ‘2016-02-05 05:31:37.693 INFO 27566 — [nio-8081-exec-8] c.armzilla.ha.upnp.UpnpSettingsResource : upnp device settings requested: amazon-ha-bridge from’

I think may be because the IP address of my Pi is not How can stop this operation to correct the IP address? Please let me know. I’m a newbie when it comes Linux commands so I appreciate any help. Thanks!

Just a thought, but I would stop all services, delete the existing Echo Bridge folder and recreate your config from scratch, then restart everything (systems hosting both OpenHAB & Echo Bridge) to see if has an impact…

Yea, I can’t figure it out still. I’m running out of options. I’m planning to just format my SD card and start from scratch. Run the raspi-config, install the Openhab, and then Echo Bridge. Hopefully, that’ll work.

I got it to work finally. It was working the whole time. I was just going to the wrong URL. I was typing *:8081/configuration.html. Instead, it suppose to be *.8081/configurator.html.

So, now I can configure items to add into the Amazon Alexa’s app Connected Home feature. But how do you keep it running in the background in the Raspberry Pi? For some reason, it would close the operation when I close my terminal window.

Ah ha! :slight_smile:

Try appending ‘&’ at the end of the CLI. This should fork it into a background process which shouldn’t close when you exit the terminal window… For instance:

java -jar amazon-echo-bridge-0.2.1.jar --upnp.config.address= --server.port=8081 &

The ideal solution is to daemonize the process so it auto starts and stops as needed, though…



I managed to run the ha-bridge (on the same raspberry I run the openhab instance) and can configure it.
But I don’t have any idea how to link the configs to my items in openhab.
Let’s say I would like to switch a light switch ON:
Switch Z_Treppenlicht "Licht Treppe" (G_Lights, G_All_OFF, G_Lights_Random) { zwave="4:2:command=switch_binary" }

How to link this into the ha-bridge?
(I would like to link it to the light button on my harmony hub remote).
Anyone who could share a config for this setup or similar?