Amazon Echo Control Binding Errors when trying to Play TuneIN


yesterday my setup suddenly broke.
I am using a Switch item to trigger a rule to play specific radio stations on my echo devices.
Now i am getting this error:

An error occurred while calling method 'ThingHandler.handleCommand()' on 'org.openhab.binding.amazonechocontrol.internal.handler.EchoHandler@f1678f': POST url '' failed: Not Found

My Echo Input “thing” shows offline and i can control it (play, pause, volume etc.).

I am on the 3.1 stable on a debian VM (openhabian image).

Here’s my config and rule:

String                     EG_Kueche_Echo_RadioStationId               "TuneIn Radio Station Id"                                   (EG_Kueche_Echo_Gruppe)                                         {channel="amazonechocontrol:echo:Jonas:EG_Kueche_Echo:radioStationId"}

Switch                     EG_Kueche_Radio_Bob                                                                                     (gKNX_Restore,gKuecheRadio)                                                  {channel="knx:device:bridge:knx_device:EG_Kueche_Radio_Bob"}

Group:Switch:OR(ON,OFF)    gKuecheRadio
rule "Radio Bob auf Echo Küche"
    Item EG_Kueche_Radio_Bob changed
    if (EG_Kueche_Radio_Bob.state == ON)
        EG_Kueche_Echo_RadioStationId.sendCommand('s106505')   //auslesen
    if (EG_Kueche_Radio_Bob.state == OFF)
            if (gKuecheRadio.state == OFF)

and the thing:

     Thing echo     EG_Kueche_Echo                "Echo Kueche"            @ "Küche"                     [serialNumber="G090VV048516008X"]

Any ideas?
I also tried updating to the latest milestone but it did not resolve the issue so i came back to the stable version.

Thank you!

Can you tell which item is linked to which channel?

Yes see the item definition.
Radio station id item is linked to the amazonechocontrol.
The switch is linked to a knx button.
But the rule triggers so it is definitely an issue with either the string i send or the binding

Sorry, didn‘t scroll far enough. I‘ll check that.

Thanks for reporting. I have spoken with the Alexa maintainers of FHEM and ioBroker, and they report the same issue, so it seems to be a change on Amazon’s servers. We’ll investigate that.

1 Like

I have the same issue even with 3.2 snapshot. Thanks.

Thanks a lot!


Funny thing is programmed it just one day before it broke so i was wondering what was going on suddenly :wink:

It’s also broken from the Browser (I use, so it’s not related to our implementation.

I would suggest to use the textCommand channel and send something like “Spiele Radio Bob auf TuneIn” (“Play Radio Bob on TuneIn”). That works for me and also saves you from the work of getting the station id.


Nice idea, i will check that out!

Hi Jan, thanks for the hint.
This is working for the single devices. How would you handle this with alexa mulitroom devices? (wha)
There is no possibilit to send textCommands.


It should work if you just choose any device and add the name of the mr-group: play music on first floor


Ahh so easy. Thank you so much.

Thanks, I didn’t knew that.

That’s weird because I cannot see any textCommand channel on any echo devices things.

It‘s an „advanced“ channel. Which version are you using?

But as a work around, I created a routine on the alexa app and then I call this routine from OH by using startRoutine channel. And still no textCommand even in the advanced channel.

Did you upgrade from a previous version? The textCommand channel was added some time ago and unfortunately openHAB does not update existing things. If you created the thing from discovery, you can delete the thing, re-discover it and all channel-links stay.

Instead of textCommand you can use the playMusicVoiceCommand channel.
Unfortunately nether are available for wha things, so I still can’t see an easy way to start radio on a speaker group.

Hi Forum,

are there new information for this “bug”?

I have tried it after openHAB 3.2.0 and Amazon Echo Control 3.28 update.
It seams thate the “TuneIn” is still broken at Amazon (I have tried also the URL und I’ll get an “” exception in the Amazon-WebUI).

Best regards,

If Amazon removed that feature, there is not much we can do.

1 Like