Amazon Echo Control Binding issue since moving to 4.0.1

I am on a fresh build of OH 4.0.1, not an upgrade. I am having issues with my 2 Pioneer Air Conditioners going Online and Offline every couple minutes. The debug shows endpoint unreachable when it goes offline. This is seen as a Thermostat Appliance. It does not have this issue in 3.4. In fact, if I disable it in 4.0.1 and enable it in 3.4. it stays online and works properly in 3.4. All my other Amazon connected devices work fine. Thank you

2023-08-14 11:26:52.476 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘amazonechocontrol:smartHomeDevice:07c1033103:18a90567-35c0-4955-9aaf-cd41641698a6’ changed from UNKNOWN: State not found to ONLINE

2023-08-14 11:27:22.692 [INFO ] [ab.event.ThingStatusInfoChangedEvent] - Thing ‘amazonechocontrol:smartHomeDevice:07c1033103:18a90567-35c0-4955-9aaf-cd41641698a6’ changed from ONLINE to UNKNOWN: State not found

I have noticed this with other smart devices connected through the Amazon Skill. Two different TP-Link smart plugs are doing this also. It only seems to effect smart devices connected through the Amazon Echo control binding. They all worked fine before moving to 4.0. Now they all just keep going offline and then online. I have tried removing and re-adding them to no avail. I am now on 4.0.3 and no change. Thank you.

I have now done testing to show that this issue does not exist in OH 3.4.1. It only happened after moving to OH 4. It appears that the binding has a problem with Smart devices connected through the Amazon Echo control binding.

I am also seeing various devices from the Echo binding going offline/onlinein OH4. Happy to help debug.

My temporary work around was to build a 3.4.2 remote server just to capture these items and pass them to my master. Thank you.

Hi all,

I am experiencing the same issues with my 4.0.3 installation. Is there any solution to this Problem known?
I found old Community Threads with the same problem, but also no solution :frowning:


I have not seen any movement on this one yet. I had to add 2 extra remote servers running 3.4.2 to get around this issue. I can’t believe more people aren’t seeing the same issues. I am also seeing the TP-Link KASA binding broken for newer devices that apparently use a different port to talk. Thanks

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.