Amazon echo control binding Last Voice Command not working anymore

Hi,
I am using oh 3.0.1. I use the amazon echo control binding since some time without any issue.
I have items bound to the Last Voice Command channel and rules reacting on it. Worked very smoothly. But since some days Last Voice Command is not working anymore. I don’t get any update and see nothing in the log. Amazon Echo things are up and running. Did anything change here or has anybody an idea?
Thanks and Regards,
Alex

You are not alone.
Look here: Web Socket Error on AmazonEchoControl binding every 65 seconds - #386 by sujitrp

Is there a solution for this issue?
There´s no solution in the linked thread and the fixed bindings are not linked anymore.
@J-N-K Should your fix be available in the latest binding version at jfrog?
https://openhab.jfrog.io/ui/native/libs-pullrequest-local/org/openhab/addons/bundles/org.openhab.binding.amazonechocontrol/3.2.0-SNAPSHOT

I installed this version and the last voice command isn´t working while other things like TTS working fine.

It is not contained in the version you linked.

And where can i find the fix, because the links in your original post are removed.

Just upgraded from 3.0.1 to 3.1.1. The 3.1.7-SNAPSHOT version I used before is not working anymore. It shows the following error in the log.

Is there an updated version for 3.1.1 availiable?

org.osgi.framework.BundleException: Could not resolve module: org.smarthomej.binding.amazonechocontrol [236]

Unresolved requirement: Import-Package: javax.measure; version="[1.0.0,2.0.0)"

at org.eclipse.osgi.container.Module.start(Module.java:463) ~[org.eclipse.osgi-3.16.200.jar:?]

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel$2.run(ModuleContainer.java:1845) ~[org.eclipse.osgi-3.16.200.jar:?]

at org.eclipse.osgi.internal.framework.EquinoxContainerAdaptor$1$1.execute(EquinoxContainerAdaptor.java:136) ~[org.eclipse.osgi-3.16.200.jar:?]

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1838) ~[org.eclipse.osgi-3.16.200.jar:?]

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1781) ~[org.eclipse.osgi-3.16.200.jar:?]

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1743) ~[org.eclipse.osgi-3.16.200.jar:?]

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1665) ~[org.eclipse.osgi-3.16.200.jar:?]

at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1) ~[org.eclipse.osgi-3.16.200.jar:?]

at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:234) [org.eclipse.osgi-3.16.200.jar:?]

at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:345) [org.eclipse.osgi-3.16.200.jar:?]

Fixed it by using 3.2.7

1 Like

Where have you found the 3.2.7 version?

There´s already a 3.2.8 version available…
https://repo1.maven.org/maven2/org/smarthomej/addons/bundles/org.smarthomej.binding.amazonechocontrol/

1 Like

Please note that you should install the kar, not the jar file if you use 3.2.8, otherwise you‘ll find an error about a missing dependency in your log.

Thanks for the info, i´m using the 3.2.7 and the last voice command is working again.

1 Like

Hi,
I followed the link, found the amazonechocontrol_3.2.10 and installed it via kar-file.
My linux knowledge is still quite limited - and by doing this I know have 2 versions, both are listed as active and of course openhab uses the wrong one…

openhab> kar:install file:/etc/openhab/tmp/amazonechocontrol-3.2.10.kar
openhab> list -s | grep amazon
330 x Active x 80 x 3.2.0 x org.openhab.binding.amazonechocontrol
331 x Active x 80 x 3.2.10 x org.smarthomej.binding.amazonechocontrol

What can I do to fix this and how I can I do it right?
Any help or helpful link to fill my knowledge holes is really appreciated!
Kind regards,
Stefan

Just uninstall from the UI.

Thank you for the fast answer! I followed your guidance and it works again!
The echoControlBinding isn’t any longer shown as installed now.
Should I expect difficulties with next update?

No, if you don’t click on “install” again, you’ll not run into issues. But you’ll not receive updates for the binding, if you install the .kar manually and the binding will not show up in the “installed bindings” list.

That’s what I expected - no updates…
I tried to uninstall the older version in karaf, but I must have done something wrong.
When I want to uninstall the newer version is this the right syntax?

kar:uninstall org.openhab.binding.amazonechocontrol-3.2.0

It didn’t work…
Thanks for your time you already spent !

What is the „old“ version? The one from the distribution? Then uninstall it the same way you installed it (UI/addons.cfg). The manually installed .kar? Delete it WHILE OPENHAB IS RUNNING.

Understood! Thanks again!

Hm, I’ve also installed the patched amazon binding 3.2.7 a while ago via addons folder. Now I just updated to OH 3.2.0. Now I’m wondering if that version already provides the fixed version or if I should keep continue using the latest (SNAPSHOT) version of the binding. What is the recommendation here? Thanks!

The binding bundled with openHAB 3.2.0 does not contain the fix.

Ok, then I stick with 3.2.10 kar. Seems to work. One last question If I may ask. In the release notes there’s talk of the new UI in 3.2.0 for the alexa binding. Looking at it, it looks like before :). Is it coming with 3.3 then?