Amazon Echo Control Binding TTS not Working

I recently migrated from OH 2.5.12 to OH 3.2.0

before doing so TTS worked properly on OH2. Now on OH3 TTS is not doing anything.

Account is Linked, Things are online, and items/channels are linked properly. When sending the command to the TTS item it shows in my log that the command was sent but no action happens. No errors or warnings are present.

I was recently getting this showing in my log, which I found out was binding related according to a post I was searching, the last few days but even with this OH2 still played the TTS commands .

 [control.internal.WebSocketConnection] - Web Socket close 1005. Reason: null

These errors stopped showing up in my log around 12PM Central time ( About 6 hours ago)

Any ideas why it is not working? Is this an Echo bug going on that may be related to the errors.


I found this and updated the binding in the post and it is now working properly. if anyone has this problem this was my solution.

uninstalled binding from marketplace and put the org.smarthomej.binding.amazonechocontrol-3.2.7-SNAPSHOT.jar in the addons folder and now works.

BTW, running openhab-3.2.0.M3

1 Like

If you are running 3.2.0 I guess you used 3.2.7, because 3.1.7 will probably not work in your setup.

Sorry, you are correct, typo. I did use snapshot 3.2.7 Edited post. Thanks

Why have the links in the original post been removed? Are these update files no longer valid?


I’m also searching for the bugfix addon version.

1 Like

My TTS does also not work anymore since update to OH 3.1.1
The “Web Socket close 1005” message stopped, but TTS does still not work.
No warning or errors in the log … Alexa does simply not speak :frowning:
The SNAPSHOT file is not available anymore …
Any other suggestion?

Hi, I switched to 3.3.0.M1 with org.openhab.binding.amazonechocontrol-3.3.0-SNAPSHOT.jar and found LastVoiceCommand not working again.
It works with org.smarthomej.binding.amazonechocontrol-3.2.7.jar though.
Can someone confirm?


1 Like

same here. I am using 3.3.0.M1 and tts is delayed. Also that annoying “socket close” message is back again.
I switched to “org.smarthomej.binding.amazonechocontrol-3.2.7-SNAPSHOT.jar”… and good again

I would upgrade to this version. Additionally features (Alexa air quality metering and Tile integration) and bug fixes.

Best, Jay


Thanks, Jay. I did upgrade :slight_smile:
regards, Kai