Web Socket Error on AmazonEchoControl binding every 65 seconds

We are working on it.


I’m quite new to openHAB and have same problem. I still have version 2.5.10 of Amazon Echo Control Binding installed and also openHAB 2.5.10 (on raspberry pi wheezy). I assume if this problem will be solved, it will happen with the newest release or? Can I installed this repaired binding even I will not update openHAB? I’m afraid of install new openHAB version, because it took me a long time to get it running and telling me local raspberry pi variables on request (like temperature, voltage etc.) on verbal request to echo.

1 Like

I‘ll provide fixed versions for 3.0/3.1/3.2 but codebase is too different to create a fix for 2.5.

3.1/3.2 will be available this evening, 3.0 in the next days.


Where will be the download place for the fixed binding ?

Is there any chance to get a fix for 2.5 in the future?



  • Uninstall amazonechocontrol binding (important, you’ll run into all sorts of trouble if you run two bindings at the same time)
  • Download the updated addon (see below)
  • Drop downloaded file in your addons folder

For openHAB 3.1.0 (M5 or release) and 3.2.0 (before M3): removed
For openHAB 3.0.x and 3.1.0 (M1-M3) : removed
For openHAB 3.2.0 (M3 and later): removed

In case of any problems: please provide a DEBUG level log of org.smarthomej.binding.amazonechocontrol.internal.websocket via PM to me (publishing here could reveal your Amazon customer id).

Regarding 2.5.x: Not from my side. As I said above: The code base (especially for the web socket part) is IMO too different for backporting.


There was a developer who fixed the authentication issues earlier this year that was part of release 2.5.13 somewhere on this forum. Ideally if we can find this person, we can get this fixed for the 2.5.x folks.

@michi , maybe you can help or know the last person that updated the binding?

Best, Jay

Hi @jlekhter , can you help us with a 2.5.13 version fix to resolve last command channel throwing errors now?

Best, Jay

1 Like

Thanks a lot! Works again for 3.2.0 M3.

1 Like

I thought oH 2.5.12 was the last version of 2.5 branch?

Thank you for your fix.
But with the new binding, the announcements do not work anymore…
can anybody confirm this?

Here’s the 2.5.13 but does have the issue reported on this thread.

Best, Jay

Can you show what exactly is not working?

Thank you. This fix works for me openhab 3.1.0 release


Echo_Arbeitszimmer_Announcement.sendCommand(‘Hallo’) …is working

Echo_Arbeitszimmer_Announcement.sendCommand(’{“sound”: false, “title”: “SmartHome”, “body”: “Dies ist ein Test”}’) …is working (no sound but text)

Echo_Arbeitszimmer_Announcement.sendCommand(’{“sound”: true, “title”: “SmartHome”, “body”: “Dies ist ein Test”}’) …not working (nothing happen)

With the old binding, the 3rd syntax was showing the text on the display, with a “gong” but no spoken words…it would be great, when this could work again…

this problem was still there in one of the previous versions…and was fixed from you.
it occurs when the “speak”-tag does not exist…

i used winscp but i don’t know where i have to put https://download.smarthomej.org/org.smarthomej.binding.amazonechocontrol-3.2.7-SNAPSHOT.jar
could you help me? what folder?? …grazie

Hello people, I’m trying to copy the jar in “/usr/share/openhab/addons” using WinSCP but I got this message
“Permission denied.
Error code: 3
Error message from server: Permission denied”. How can I copy the jar into the addon folder?

1 Like

Which user? Sounds like a permission issue?

The user is “openhabian”… yes this is a permission issue, I’m a beginner on Linux. Thanks

Later edit : I used putty and I downloaded the file using "sudo wget link " :smiley: (1st time I tried to copy the file from Windows to Openhab using WinSCP)


1 Like