Amazonechocontrol newest version


Where do I find the newest version of “org.openhab.binding.amazonechocontrol”?
I have 3.1.0 and it seems to have a bug: “Web Socket close 1005. Reason: null”


As far as I understand you need to switch to OH 3.2 to get the latest snapshot.

Thanks for your reply.

I would think it was possible to only update one binding to the newest version without updating OH, but maybe I am wrong.

1 Like

At JFrog the latest version 3.1.0 was created on 27.06.2021.
3.2.0 snapshot at JFrog has a timestamp from 10.12.2021.
I am not sure if the 3.2.0 snapshot runs under 3.1.0.

I have tried and it looks like you are correct: The 3.2.0 binding does not run under OH 3.1.

I have the 3.2.0.M4 binding and the “Web Socket close 1005. Reason: null” bug is still present.

The same here. I have 3.2.0-SNAPSHOT - Build #2618, but still get the
“Web Socket close 1005. Reason: null” bug.

The bug “Web Socket close 1005. Reason: null” is solved in



Where can I download 3.2.7?

1 Like

I found a newer version: on openHAB3-Distribution [Jenkins]
but unfortunately it has the error.

I do not know where to look for 3.2.7 as it has been removed from:

Hi there,

I also have the known bug i amazonechocontrol binding.
I just raised my Openhab to 3.2.0. Here, too, the error is still present.

I also need version 3.2.7-SNAPSHOT.
The given link no longer works. Where can I get the current version?

See here.


here you can download the newest version - I think it’s already 3.28